关于二分题(晾干衣服)的结题报告

题目:

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1 3
2 3 9
5 sample input #2 3
2 3 6
5

Sample Output

sample output #1 3 sample output #2 2

题目大意:

有N件湿衣服,含水量分别为a i,烘干机每分钟可烘干K滴水。问烘干全部衣服的最少时间

解题思想:

本题可以考虑二分,将时间二分,时间为1到最大含水量max,首先自然风干m分钟,剩余的使用烘干 机,比较两者的时间大小,直到找到符合的时间

代码如下:

#include<stdio.h>
long long a[100001],n,k;
long long dry(long long m)//计算时间是否够用,如果时间不够:正;
{
    long long t,i,now;
    t=0;
    for(i=1;i<=n;i++)
    {
        now=a[i]-m;
       if(now>0)
       {
          t+=(now+k-2)/(k-1);
       }
    }
    return t-m;
}

long long time(long long x,long long y)//在区间内二分找合适的时间
{
    long long m=(x+y)/2;
    while(y>=x)
    {
        m=(x+y)/2;
        if(dry(m)==0) return m;
        else if(dry(m)>0) x=m+1;
        else y=m-1;
    }
}
main()
{
    long long max,i;
    while(scanf("%lld",&n)!=EOF)
    {
        for(max=i=1;i<=n;i++)//找到最大时间
        {
            scanf("%lld",&a[i]);
            if(i==1)
                max=a[max];
            else if(max<a[i])
                max=a[i];
        }
        scanf("%lld",&k);
        if(k<=1)
             printf("%lld\n",max);
        else
        {
            max=time(1,max);
            printf("%lld\n",max);
        }

    }

}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值