HDU1022(解题报告)

                                                                                                      Train Problem I

                                                       Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
 

Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

Sample Input

    
    
3 123 321 3 123 312
 

Sample Output

    
    
Yes. in in in out out out FINISH No. FINISH

Hint

Hint  For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".
        












解题思想:本题大意为,输入n列火车,然后分别输入火车的入站顺序和出站顺序,问能否出站。
          模拟栈问题,用in来存入栈顺序,out来存出栈顺序,v数组来标记入栈和出栈,如果栈首元素和出栈的栈首元素相等,则弹出,相应的栈首下标--,
          出栈下标++;如果不等,则继续通过S数组入栈,直到i>n(入栈车的个数超过n)停止。最后如果栈首元素还为起始值的话,说明进来的列车都已出栈,
          否则,没有完全出栈。















解题代码:
#include <stdio.h>
#include <string.h>
int s[10000];
int v[10000];
char in[10000];
char out[10000];
int main()
{
    int n,i,j,k,top;
    while(scanf("%d%s%s",&n,in,out)!=EOF)
    {
        i=0;
        j=0;
        k=0;
        top=-1;
        memset(v,0,sizeof(v));
        while(j<n)
        {
            if(top==-1 || s[top]!=out[j] && i<n)
            {
                s[++top]=in[i++];
                v[k++]=1;
            }
            else
            {
                if(s[top] == out[j])
                {
                    top--;
                    ++j;
                    v[k++]=0;
                }
                else
                    break;
            }
        }
        if(top==-1)
        {
            printf("Yes.\n");
            for(i=0;i<k;i++)
            {
                if(v[i])
                    printf("in\n");
                else
                    printf("out\n");
            }
            printf("FINISH\n");
        }
        else
            printf("No.\nFINISH\n");
    }
}


  • 1
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值