HDU1003

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 127665    Accepted Submission(s): 29582


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

   
   
刚开始我想的方法是把子数组全部找到,用sum_max,min,max存放结果超时了,然后看到这种解法
下面是AC代码:
#include<iostream>
#include<string>
#include<map>
using namespace std;
int a[100000];
int main()
{
	int n,m,i,j,flag=1;
	cin>>n;
	while(n--)
	{
		
		cin>>m;
		for(i=0;i<m;i++)
			cin>>a[i];
		cout<<"Case "<<flag<<':'<<endl;
		int mi=0,ma=0;//mi是开始,ma是结尾
		int pos=0;//pos作为一个存放临时初始位置
		int sum,max_sum;//sum存放变化的最大值,max_sum存放最终的最大值
	        sum=max_sum=a[0];
		for(i=1;i<m;i++)
		{ 				
			 sum+=a[i];
			if(a[i]>sum)
				{
					sum=a[i];
					pos=i;
				}//找到起始位置i
			if(sum>max_sum)
			{
				max_sum=sum;
				mi=pos;
				ma=i;
			}//不断的更新最大值,然后记下最后的位置
			
		}
		cout<<max_sum<<' '<<mi+1<<' '<<ma+1<<endl;
		flag++;
		if(n!=0)cout<<endl;//格式要求,最后一行没有空格
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值