hdu1059(多重背包)

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15305    Accepted Submission(s): 4247


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

Output a blank line after each test case.
 

Sample Input
  
  
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
  
  
Collection #1: Can't be divided. Collection #2: Can be divided.
 

题意:

输入:1 0 1 2 0 0,  六个数字说明有6堆石头,数字表示石头的个数,他们的下标为他们的价值,题目的要求是怎样能将石头分成价值相同的两堆,如第一组数据,有一个价值为1的石头,一个价值为3的石头,2个价值为4的石头,没法分为两堆相同的石头,所以输出can't be divided;

解题思路:

首先想如果要将石头分为两堆,那么石头的总价值必须为偶数,只有偶数才能被平分,然后可以将石头的总价值的一半作为背包,石头的数量很大,所以为多重背包,

但如果一个一个的取,用3个for循环必然超时,所以有用的优化的2进制思想;

看代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<algorithm>
#include<cmath>
using namespace std;
#define Max(a,b) a>b?a:b
#define  Min(a,b)  a<b?a:b
#define inf 99999999
int dp[120020],num[7],sum;

void zero_one(int cost,int weight)//01背包
{
    for(int j=sum;j>=cost;j--)
    {
        dp[j]=Max(dp[j],dp[j-cost]+weight);

    }
}
void totle_pack(int cost,int weight)//完全背包
{
    for(int j=0;j<=sum;j++)
    {
        if(j>=cost)
            dp[j]=Max(dp[j],dp[j-cost]+weight);
    }
}
void multiple_pack(int cost,int weight ,int n)//多重背包
{
    if(n*cost>=sum)
        totle_pack(cost,weight);
    else
    {
        int k=1;
        while(k<n)
        {
            zero_one(cost*k,weight*k);
            n-=k;
            k*=2;
        }
        zero_one(n*cost,n*weight);
    }

}

int main()
{
    int t=1;
    while(1)
    {
        sum=0;
        for(int i=1;i<=6;i++)
        {
            cin>>num[i];
            sum+=num[i]*i;
        }
        if(sum==0)break;
        
        cout<<"Collection #"<<(t++)<<':'<<endl;
        if(sum%2==1)
        {
            cout<<"Can't be divided."<<endl<<endl;
        }
        else
        {
            sum/=2;
            for(int i=0;i<=sum;i++)
                dp[i]=0;
            for(int i=1;i<=6;i++)
            {
                if(num[i])
                multiple_pack(i,i,num[i]);
            }
            if(dp[sum]==sum)
                cout<<"Can be divided."<<endl<<endl;
            else
                cout<<"Can't be divided."<<endl<<endl;
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值