poj2923 Relocation(压缩dp+01背包)

Relocation
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1822 Accepted: 748

Description

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

  1. At their old place, they will put furniture on both cars.
  2. Then, they will drive to their new place with the two cars and carry the furniture upstairs.
  3. Finally, everybody will return to their old place and the process continues until everything is moved to the new place.

Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input

The first line contains the number of scenarios. Each scenario consists of one line containing three numbers n, C1 and C2. C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.

Sample Input

2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98

Sample Output

Scenario #1:
2

Scenario #2:
3

题意:

有两辆车拉东西,每辆车能拉多少东西已知,有n个物品需要拉走,问题是至少需要多少趟能将物品全部拉走?

解题思路:

将每种能拉的可能存放在一个数组中( 压缩后的数组中不含相同的两种选法 )(状态压缩),然后用背包来选取最优的解(01背包)

值得注意的是在这里n最大为10,也就是说就算是枚举出所有可能的选择,最大也只有2的10次方种选择,所以用二进制来压缩数组,不算太大!

状态转移方程:

dp[j|k] = min(dp[j|k],dp[k]+1) 
代码:

#include<iostream>
#include<stdio.h>
#include<string>
#include<queue>
#include<string.h>
#include<cmath>
#include<algorithm>
#include<math.h>
using namespace std;
const int inf=0x3f3f3f3f;

const  int Max=1100;
int n,c1,c2,w[11],vis[Max],dp[Max],q[Max];
bool judge(int x)
{
     memset(vis,0,sizeof(vis));
     vis[0]=1;
    int sum=0;
    for(int i=0;i<n;i++)
    {
        if(x&(1<<i))
        {
            sum+=w[i];
            for(int j=c1-w[i];j>=0;j--)
            {
                if(vis[j])
                    vis[j+w[i]]=1;//如果vis[j]的值满足,那么vis[j+w[i]]的值也可运
            }
        }
    }
    for(int i=c1;i>=0;i--)//判断第二辆车是否能装完
    {
        if(sum-i<=c2&&vis[i])
            return true;
    }
    return false;
}                        //用二进制的匹配来筛选可能的所有组合,如果这里不懂可以模拟运行下,0.0(我也搞了好久才懂的)
int main()
{
    int t,T;
    while(cin>>T)
    {
        t=1;
        while(T--)
        {
            cin>>n>>c1>>c2;
            for(int i=0;i<n;i++)
                cin>>w[i];
            int flag=0;             //记录总共有多少种搬运方式
            for(int i=0;i<(1<<10);i++)
                if(judge(i))
                    q[flag++]=i;//将所有的搬运方式放在q[]中,没有重复的搬运方式
            for(int i=1;i<=(1<<n);i++)dp[i]=inf;
            dp[0]=0;
            for(int i=0;i<flag;i++)
                for(int j=(1<<n);j>=0;j--)
            {
                if(dp[j]==inf)continue;
                if((j|q[i]))
                    dp[j|q[i]]=min(dp[j|q[i]],dp[j]+1);//如果满足q[i]这种组合的搬运,就需要增加一次搬运dp[j]+1
            }
             printf("Scenario #%d:\n%d\n\n",t,dp[(1<<n)-1]);
            t++;
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值