POJ 3278 Catch That Cow

Catch That Cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4


题目的意思是去抓牛,给出了人和牛的位置,而且牛不会动,人可以有三种走法分别是x-1,x+1,x*2。。问最少走的步数。。

唉。。。贡献了无数的RE。。原因是范围多了1....题目不难就是一个简单三个方向的BFS。。。上代码:



#include <stdio.h>
#include <string.h>
#include <stdlib.h>

struct node
{
    int x,ans;
} q[1000001];
int vis[1000001];
int n,k;
int jx[]={1,-1};
void BFS ()
{
    int i;
    struct node t,f;
    int s=0,e=0;
    t.x=n;
    t.ans=0;
    q[e++]=t;
    vis[t.x]=1;
    while (s<e)
    {
        t=q[s++];
        if (t.x==k)
        {
            printf ("%d\n",t.ans);
            break;
        }
        for(i=0;i<3;i++)
        {
            f.x=t.x+jx[i];
            if (i==2)f.x=t.x*2;
            if(vis[f.x]==0&&f.x>=0&&f.x<=100000)
            {
                f.ans=t.ans+1;
                q[e++]=f;
                vis[f.x]=1;
            }
        }
    }
}

int main ()
{

    while (~scanf ("%d%d",&n,&k))
    {
        memset(vis,0,sizeof (vis));
        BFS();
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值