POJ 2965 The Pilots Brothers' refrigerator

The Pilots Brothers' refrigerator

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4



题意==:大象要把冰箱门打开,问所需最少步数。冰箱门有16个开关,‘-’代表开着,当16个开关都开着的时候才能把冰箱门打开。每次只能从16个开关里选择一个进行操作,这个开关所在的行和列的每一个开关的状态也要改变。

这个题和POJ1753很类似的。这个题的代码也是从1753上改过来的。所以所需的步数很快就出来了,而下面所输出的每一步进行操作的开关的位置却迟迟弄不出来。。还是看的Hypo的题解。。又定义了 ansx,ansy数组来更新记录每次达到16个‘-’的时候的x,y,的坐标。定义了zx,zy数组 保存的是 翻下一个时候的x,y坐标。当满足判断条件而且新的步数<ans的时候对ansx,ansy数组进行更新。

PS:POJ1753解题报告



#include <stdio.h>

const int inf=9999999;
char s[10];
int map[10][10],i,j,l=0,r=0;
int ans =inf;
int ansx[inf],ansy[inf],zx[inf],zy[inf];

int panduan()
{
    for (i=0; i<4; i++)
    {
        for (j=0; j<4; j++)
        {
            if (map[i][j]!=0)
                return 0;
        }
    }
    return 1;
}

void fan (int x,int y)
{

    for (i=0; i<4; i++)
    {
        map[x][i]=!map[x][i];
        map[i][y]=!map[i][y];
    }
    map[x][y]=!map[x][y];

}

int dfs (int x,int y,int t)
{
    if ( panduan ())
    {
        if (ans > t)
        {
            ans = t;
            for (i=0; i<ans; i++)
            {
                ansx[i]=zx[i];
                ansy[i]=zy[i];
            }
        }
        return 0;
    }
    if (x >= 4 || y >= 4)
        return 0;
    int nx,ny;
    nx = (x + 1 ) % 4;
    ny = y + ( x + 1 ) / 4;

    dfs (nx,ny,t);
    fan (x,y);

    zx[t]=x+1;//翻下一个的时候x坐标
    zy[t]=y+1;//翻下一个的时候y坐标

    dfs (nx,ny,t+1);
    fan (x,y);


    return 0;
}

int main ()
{
    for (i=0; i<4; i++)
    {
        scanf ("%s",s);
        for (j=0; j<4; j++)
        {
            if (s[j]=='-')
                map[i][j]=0;
            else
                map[i][j]=1;
        }
    }
    dfs (0,0,0);

    printf ("%d\n",ans);
    for (i=0; i<ans; i++)
    {
        printf ("%d %d\n",ansx[i],ansy[i]);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值