50 years, 50 colors
Problem Description
On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".
There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.
Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.
There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.
Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.
Input
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
Output
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".
Sample Input
1 1 1 2 1 1 1 1 2 2 1 1 2 2 2 5 4 1 2 3 4 5 2 3 4 5 1 3 4 5 1 2 4 5 1 2 3 5 1 2 3 4 3 3 50 50 50 50 50 50 50 50 50 0 0
Sample Output
-1 1 2 1 2 3 4 5 -1
题意:
一个n*n的矩阵,每个格子放一种颜色(1-50),每个数字代表一种颜色,每次可以选择一行或者一列同种颜色的气球消掉,操作k次之后哪种颜色的气球还有剩余。
1-50一次枚举最大匹配,如果该点的最大匹配数大于k,则在k次操作内是不可能消除干净的。
按升序输出不可能消除干净的气球。
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
using namespace std;
int map[110][110],vist[110],link[110];
int num[110],ans[110];
int n,k;
int cmp (const void *a,const void *b)
{
return *(int *)a - *(int *)b;
}
int dfs (int a,int b)
{
for (int i = 1; i <= n;i++)
{
if ( vist[i] == 0 && map[b][i] == a)
{
vist[i] = 1;
if ( link[i] == -1 || dfs (a,link[i] ))
{
link[i] = b;
return 1;
}
}
}
return 0;
}
int main ()
{
while (~scanf ("%d%d",&n,&k) && (n || k))
{
memset (num,0,sizeof (num));
for (int i = 1; i <= n; i++)
{
for (int j = 1; j <= n; j++)
scanf ("%d",&map[i][j]);
}
int flag = 0,sum = 0;
for (int i = 1; i <=50; i++)
{
memset (link,-1,sizeof (link));
for (int j = 1; j <= n; j++)
{
memset (vist,0,sizeof (vist));
num[i] += dfs (i,j);
}
if (num[i] != 0 && num[i] > k)
{
flag = 1;
ans[sum++] = i;
}
}
if ( flag == 0)
printf ("-1\n");
else
{
qsort (ans,sum,sizeof (ans[0]),cmp);
for (int i = 0; i < sum; i++)
{
printf ("%d",ans[i]);
if ( i < sum -1)
printf (" ");
else printf ("\n");
}
}
}
return 0;
}