2014春季ACM集训_基本算法------F---------Ubiquitous Religions (并查集)

Ubiquitous Religions

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 
 
You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

输入

 The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

输出

 For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

示例输入

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

示例输出

Case 1: 1
Case 2: 7


寒假之后填的第一个坑。。。并查集先生。。

寻找有几个小集合,从最下面的一个点找起看是不是最外面的一层的点能寻找到同一个顶点,或者能找到几个顶点。

这个题就是从每个学生向上找,看能找出几个集合或者说找出几个根节点就是有几个宗教



#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int bin[501010];//保存返回的顶点数
/*int findx(int x)//可以这样写的,但是没有路径压缩。。不太好
{
    int r;
    r=x;
    while(bin[r]!=r)
    {
        r=bin[r];
    }
    return r;
}*/
int findx(int x)
{
    int r,k,j;
    r = x;
    while(r!=bin[r])//查找根节点
    {
        r=bin[r];//找到根节点,并且用r记录
    }
    k=x;
    while(k!=r)//此乃路径压缩。。。
    {
        j=bin[k]; //中间变量j暂时保存bin[r]的父节点
        bin[k] = r;//bin[k]指向根节点
        k = j;     //k移动到父节点
    }
    return r;
}
void Merge(int x,int y)
{
    int fx,fy;
    fx=findx(x);
    fy=findx(y);
    if(fx!=fy)
    {
        bin[fx]=fy;
    }
}

int main()
{
    int n,m;
    int x,y;
    int i;
    int t,k;
    t=0;
    while(~scanf("%d %d",&n,&m))
    {
        t++;
        if(n==0&&m==0)break;
        for(i=0;i<n;i++)
        {
            bin[i]=i;
        }
        while(m--)
        {
            scanf("%d %d",&x,&y);
            Merge(x,y);
        }
        for(k=0,i=0;i<n;i++)
        {
            if(bin[i]==i)
            {
                k++;
            }
        }
        printf("Case %d: %d\n",t,k);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值