K-based Numbers (SDUT 2062)

10 篇文章 1 订阅

K-based Numbers

Time Limit: 1000MS Memory limit: 65536K

题目描述

Let’s consider K-based numbers, containing exactly N digits. We define a number to be valid if its K-based notation doesn’t contain two successive zeros. For example:
(1)1010230 is a valid 7-digit number;
(2)1000198 is not a valid number;
(3)0001235 is not a 7-digit number, it is a 4-digit number.
Given two numbers N and K, you are to calculate an amount of valid K based numbers, containing N digits.
You may assume that 2 ≤ K ≤ 10; N ≥ 2; N + K ≤ 18.

输入

The numbers N and K in decimal notation separated by the line break.

输出

The result in decimal notation.

示例输入

2 10

示例输出

90

提示


来源


示例程序



#include <stdio.h>
int main()
{
    int f[31];
    int n,k,i;
    while(~scanf("%d %d",&n,&k))
    {
        if(n==1)
        {
            printf("%d\n",k);
            break;
        }
        f[1]=k-1;
        f[2]=(k-1)*k;
        for(i=3;i<=n;i++)
            {
                f[i]=(k-1)*(f[i-1]+f[i-2]);
            }
        printf("%d\n",f[n]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值