How many prime numbers(水题)

How many prime numbersCrawling in process...Crawling failedTime Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u




Description

  Give you a lot of positive integers, just to find out how many prime numbers there are.
 

Input

  There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
 

Output

  For each case, print the number of prime numbers you have found out.
 

Sample Input

     
     
3 2 3 4
 

Sample Output

     
     
2
 

求素数的个数,纯暴力解决






#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
int main()
{
	int n,m,i;
	int flag=0;
	int count=0;
	while(~scanf("%d",&n))
	{
        count=0;
		while(n--)
		{
			scanf("%d",&m);
			flag=0;
			for(i=2;i<=sqrt(m);i++)
				if(m%i==0)
				{
				    flag=1;
				    break;
                }
				if(flag==0)
                    count++;
		}
		printf("%d\n",count);
	}
	return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值