Appoint description:
Description
We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (x
i mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive root modulo 7.
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p.
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p.
Input
Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.
Output
For each p, print a single number that gives the number of primitive roots in a single line.
Sample Input
23 31 79
Sample Output
10 8 24
欧拉函数第一发。
题意:p是奇素数,如果{xi%p | 1 <= i <= p - 1} = {1,2,...,p-1},则称x是p的原根.给出一个p,问它的原根有多少个。
思路:.纯粹模版题,在这有一些概念需要知道。
原根和指数 设h为一整数,n为正整数,(h,n)=1,适合h^l=1(mod n)的最小正整数l叫做h对模n的次数。如果l=φ(n),此时h称为模n的原根
欧拉函数:在数论,对正整数n,欧拉函数是少于或等于n的数中与n互质的数的数目。
费马小定理:是数论中的一个重要定理,其内容为: 假如p是质数,且Gcd(a,p)=1,那么 a(p-1) ≡1(mod p)。即:假如a是整数,p是质数,且a,p互质(即两者只有一个公约数1),那么a的(p-1)次方除以p的余数恒等于1。
欧拉定理与费马小定理的关系:
对任何两个互质的正整数a, m, m>=2有 a^φ(m)≡1(mod m) 即欧拉定理。当m是质数p时,此式则为,a^(p-1)≡1(mod m) 即费马小定理。
这篇博客有对这道题精确的证明:点击打开链接
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;
const double pi= acos(-1.0);
int phi[66666];
void Euler()
{
int i,j;
memset(phi,0,sizeof(phi));
phi[1]=1;
for(i=2;i<=65536;i++){
if(!phi[i]){
for(j=i;j<=65536;j+=i){
if(!phi[j])
phi[j]=j;
phi[j]=phi[j]/i*(i-1);
}
}
}
}
int main()
{
int n;
Euler();
while(~scanf("%d",&n)){
printf("%d\n",phi[phi[n]]);
}
return 0;
}