Communication System

题目链接:http://poj.org/problem?id=1018

Description

We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers differ in their maximum bandwidths and prices.
By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P.

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single integer n (1 ≤ n ≤ 100), the number of devices in the communication system, followed by n lines in the following format: the i-th line (1 ≤ i ≤ n) starts with mi (1 ≤ mi ≤ 100), the number of manufacturers for the i-th device, followed by mi pairs of positive integers in the same line, each indicating the bandwidth and the price of the device respectively, corresponding to a manufacturer.

Output

Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal point.

Sample Input

1 3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110

Sample Output

0.649
题目描述:一个系统由多个设备组成,每个设备都有多个采购选择,每个选择的的带宽b和价格p不同。求这个系统的一个购买方案,使得在这个方案中所有设备中的最小带宽minb和总的费用p之比最大。思路如下:枚举所有可能方案,对于每一个设备,选择带宽最大的一个(设为maxb),对于其他设备,选择超过maxb中价格最少的,代码如下:

#include<iostream>
#include<algorithm>
#include<iomanip>
using namespace std;
struct der
{
    int p,b;
} de[101][101];
bool cmp(struct der a,struct der b)
{
    return a.p<b.p;
}
int main()
{
    int t,c[101],i,j,n;
    cin>>t;
    while(t--)
    {
        double ans=1<<20;
        cin>>n;
        for(i=0; i<n; i++)
        {
            cin>>c[i];
            for(j=0; j<c[i]; j++)
                cin>>de[i][j].b>>de[i][j].p;
            sort(de[i],de[i]+c[i],cmp);      //按照价格从小到大排序
        }
        for(i=0; i<n; i++)  
        {
            int pos=0,sp=0,flag=0;
            for(j=1; j<c[i]; j++)pos=de[i][j].b>de[i][pos].b?j:pos; //选择第i个设备中带宽最大的为de[i][pos]
            sp+=de[i][pos].p;
            for(j=0; j<n; j++)  //由于已经按照价格排好序了,从其他设备中选取第一个大于de[i],[pos].b的即可
            {
                int k;
                if(i==j)continue;
                for(k=0; k<c[j]; k++)
                    if(de[j][k].b>=de[i][pos].b)
                    {
                        sp+=de[j][k].p;
                        break;
                    }
                if(k==c[j])flag=1;//如果该选择中所有其他设备中带宽没有比de[i][pos].b更大的,则不是一个可行的方案
            }
            if(!flag)
            {
                double tmp=(double)de[i][pos].b/sp;
                if(ans>tmp)ans=tmp;
            }
        }
        cout<<setiosflags(ios::fixed)<<setprecision(3)<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值