Fibonacci

Fibonacci

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9184 Accepted: 6511

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, andFn =Fn − 1 + Fn − 2 forn ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits ofFn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., printFn mod 10000).

Sample Input

0
9
999999999
1000000000
-1


Sample Output

0
34
626
6875

题目描述:题目介绍了了一种求fibonacci数列的方法,求矩阵的n次幂模1000。和普通的快速幂类似,这里用c++写了一个矩阵类,然后重载运算符*和%,代码如下:

#include<iostream>
#include<algorithm>
#define N 31
using namespace std;
class Matrix
{
public:
    Matrix(int s);
    Matrix operator%(int mod);
    Matrix operator*(const Matrix& b);
    int n;
    int **A;
};
Matrix::Matrix(int s)
{
    int i,j;
    n=s;
    A=new int*[s];
    for(i=0; i<n; i++)
        A[i]=new int[s];
}
Matrix Matrix::operator%(int mod)
{
    int i,j;
    for(i=0; i<n; i++)
        for(j=0; j<n; j++)A[i][j]%=mod;
    return *this;
}
Matrix Matrix::operator*(const Matrix &b)
{
    Matrix tmp(b.n);
    int i,j;
    for(i=0; i<n; i++)
    {
        for(j=0; j<n; j++)
        {
            int sum=0;
            for(int di=0; di<n; di++)
                sum+=A[i][di]*b.A[di][j];
            tmp.A[i][j]=sum;
        }
    }
    return tmp;
}
Matrix pow(Matrix A,int n,int mod)
{
    if(n==0)
    {
        Matrix tr(2);
        tr.A[0][1]=0;
        return tr;
    }
    if(n==1)return A%mod;
    Matrix tmp=pow(A,n/2,mod);
    Matrix t=tmp%mod;
    if(n&0x1)
        return t*t*A%mod;
    return t*t%mod;
}
int main()
{
    int k,mod=10000;
    Matrix a(2);
    a.A[0][0]=a.A[0][1]=a.A[1][0]=1;
    a.A[1][1]=0;
    while(cin>>k,k!=-1)
    {
        Matrix b=pow(a,k,mod);
        cout<<b.A[0][1]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值