递推:Tri Tiling

http://acm.hdu.edu.cn/showproblem.php?pid=1143

Tri Tiling

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1992    Accepted Submission(s): 1130


Problem Description
In how many ways can you tile a 3xn rectangle with 2x1 dominoes? Here is a sample tiling of a 3x12 rectangle.


 

Input
Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 ≤ n ≤ 30. 
 

Output
For each test case, output one integer number giving the number of possible tilings. 
 

Sample Input
  
  
2 8 12 -1
 

Sample Output
  
  
3 153 2131


这个题一定要注意的是奇数一定要处理。。虽然不能被覆盖。。我就是因为没处理。。所以导致WA一次。。而且一直不懂的是。。n=0时。。结果是1。。23333.。ORZ

当n为奇数时,,输出0;

当n为偶数时。。a[i]=a[i-2]*4-a[i-4];

代码如下:


#include<cstdio>>
#include<cstring>
#include<iostream>
#include<algorithm>

int main()
{
    int n;
    int a[55];
    a[0]=1;
    a[2]=3;
    for(int i=4; i<=30; i+=2)
        a[i]=4*a[i-2]-a[i-4];
    while(~scanf("%d", &n) && n!=-1 )
    {
        if(n%2!=0)
            printf("0\n");
        else
            printf("%d\n", a[n]);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值