Power Strings

Power Strings
Time Limit: 1000MS    Memory limit: 65536K

题目描述

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

输入

  Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

输出

  For each s you should print the largest n such that s = a^n for some string a.

示例输入

abcd
aaaa
ababab
.

示例输出

1
4
3

提示

 This problem has huge input, use scanf instead of cin to avoid time limit exceed.

在运行整段字符串的的时候最后的的时候i-j就是字符串的最小子字符串

 

#include<stdio.h>
#include<string.h>
char t[110000000];
int next[11000000];
int main()
{
    int n,m,i,j;
    int len1;
    while(~scanf("%s",t)&&strcmp(t,".")!=0)
    {
        len1=strlen(t);
        i=0,j=-1;
        next[0]=-1;
        while(i<len1)
        {
            if(j==-1||t[i]==t[j])
            {
                ++i;
                ++j;
                if(t[i]!=t[j]) next[i]=j;
                else next[i]=next[j];
            }
            else j=next[j];
        }
        if(len1%(len1-j)==0)
        {
            int l=len1/(len1-j);
            printf("%d\n",l);
        }
        else
            printf("1\n");
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值