Flow Problem

Description

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.      
              

Input

The first line of input contains an integer T, denoting the number of test cases.       
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)       
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)      
              

Output

For each test cases, you should output the maximum flow from source 1 to sink N.      
              

Sample Input

    
    
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
              

Sample Output

    
    
Case 1: 1 Case 2: 2

 

 

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<queue>
#define oo 1<<28
using namespace std;
int n,m,map[300][300];
int a[300],p[300],flow[300][300];
int start,end;
int Dinic()
{
    int u,v;
    queue<int>q;
    memset(flow,0,sizeof(flow));
    memset(p,0,sizeof(p));
    int f=0;
    while(1)
    {
        memset(a,0,sizeof(a));
        a[start]=oo;//oo是因为起点没有节点控制,先初始为最
        q.push(start);
        while(!q.empty())//bfs找增广路
        {
            int u=q.front();
            q.pop();
            for(v=1;v<=m;v++)
            {
                if(!a[v]&&map[u][v]>flow[u][v])//找到新节点,保证要流过的小于最大界限
                {
                    p[v]=u;
                    q.push(v);
                    a[v]=a[u]<map[u][v]-flow[u][v]?a[u]:map[u][v]-flow[u][v];//最小残量,保证此增光路上每一条都可通过,否则就成了死路
                }
            }
        }
        if(a[end]==0)
            break;
        for(u=end;u!=start;u=p[u])//从汇点向回流
        {
            flow[p[u]][u]+=a[end];//正向的加上此增广路上最小的值
            flow[u][p[u]]-=a[end];//同样反向的要减去
        }
        f+=a[end];
    }
    return f;
}
int main()
{
    int i,j;
    while(~scanf("%d%d",&n,&m))
    {
        memset(map,0,sizeof(map));
        memset(flow,0,sizeof(flow));
        int u,v,w;
        for(int i=0; i<n; i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            map[u][v]+=w; //防止有重边
        }
        start=1,  end=m;//开始于1,结束于m
        printf("%d\n",Dinic());
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值