zoj1944Tree Recovery 数据结构

Tree Recovery

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 

This is an example of one of her creations:

         D
        / \
       /   \
      B     E
     / \     \
    /   \     \
   A     C     G
              /
             /
            F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious. 

So now she asks you to write a program that does the job for her!


Input

The input will contain one or more test cases. 

Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.


Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).


Sample Input

DBACEGF ABCDEFG
BCAD CBAD


Sample Output

ACBFGED
CDAB

import java.io.BufferedInputStream;
import java.io.PrintWriter;
import java.util.Scanner;


public class Main {
	
	public static void main(String[] args) {
		new Task().solve();
	}
}


class Task {
	Scanner in = new Scanner(new BufferedInputStream(System.in)) ;
	PrintWriter out = new PrintWriter(System.out);
	
	void dfs(String preorder , String inorder){
		if(preorder == null || preorder.length() == 0){
			return ;
		}
		char c = preorder.charAt(0) ;
		int i = inorder.indexOf(c) ;
		preorder = preorder.substring(1) ;
		dfs(preorder.substring(0, i), inorder.substring(0, i));
		dfs(preorder.substring(i), inorder.substring(i+1));
		out.print(c) ;
	}
	
	void solve() {
		while(in.hasNext()){
			dfs(in.next(), in.next());
			out.println();
			//out.flush(); 
	    }
		out.flush(); 
	}
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值