zoj 1944 Tree Recovery (二叉树)

30 篇文章 0 订阅
23 篇文章 0 订阅
Tree Recovery

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 

This is an example of one of her creations:

         D
        / \
       /   \
      B     E
     / \     \
    /   \     \
   A     C     G
              /
             /
            F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 

However, doing the reconstruction by hand, soon turned out to be tedious. 

So now she asks you to write a program that does the job for her!


Input

The input will contain one or more test cases. 

Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.


Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).


Sample Input

DBACEGF ABCDEFG
BCAD CBAD


Sample Output

ACBFGED
CDAB

这道题和之前做的重建二叉树 思路基本一致,那道题是已知中序和后序遍历,求前序遍历,这道题就是已知前序遍历和中序遍历,求后序遍历,由前序遍历可以得到这棵树的根节点,由中序遍历把这棵树分成两部分,然后再进行递归求解;

下面是代码:

#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
struct node
{
    char value;
    node *lchild,*rchild;//左右子树
};
node *newnode(char c)
{
    node *p;
    p=(node *)malloc(sizeof(node));
    p->value=c;
    p->lchild=p->rchild=NULL;
    return p;
}
node *rebulid(char *pre,char *in,int n)
{
    if(n==0) return NULL;
    int l_len,r_len,i;
    char s=pre[0];
    node *root=newnode(s);
    for(i=0;i<n&&in[i]!=s;i++);
    l_len=i;
    r_len=n-i-1;
    if(l_len>0) root->lchild=rebulid(pre+1,in,l_len);//递归求解
    if(r_len>0) root->rchild=rebulid(pre+l_len+1,in+l_len+1,r_len);
    return root;
}
void postorder(node *p)
{
    if(p==NULL) return;
    postorder(p->lchild);
    postorder(p->rchild);
    printf("%c",p->value);
}
int main()
{
    char preorder[30],inorder[30];
    while(scanf("%s%s",preorder,inorder)!=EOF)
    {
        node *root=rebulid(preorder,inorder,strlen(preorder));
        postorder(root);
        printf("\n");
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值