DNA Sorting

描述

One measure of "unsortedness" in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence "DAABEC", this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence "AACEDGG" has only one inversion (E and D)--it is nearly sorted--while the sequence "ZWQM" has 6 inversions (it is as unsorted as can be--exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of "sortedness", from "most sorted" to "least sorted". All the strings are of the same length.

输入

The first line contains two integers: a positive integer n (0 < n ≤ 50) giving the length of the strings; and a positive integer m (1 < m ≤ 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

输出

Output the list of input strings, arranged from "most sorted" to "least sorted". If two or more strings are equally sorted, list them in the same order they are in the input.

样例输入

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

样例输出

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

#include<iostream>
using std::cin;
using std::cout;
using std::endl;
using std::ostream;
using std::istream;
#include<cstdlib>

class DNAList{
	friend istream& operator >> (istream& in, DNAList& example);
	friend ostream& operator << (ostream& out, const DNAList& example);
	friend void sort(DNAList* ptr, const size_t& size);
public:
	DNAList(void){
		d_data = NULL;
		d_measure = 0;
	}
	DNAList(const size_t& length){
		d_data = new char[length + 1];
		d_measure = 0;
	}
	DNAList(const DNAList& src){
		d_data = new char[strlen(src.d_data) + 1];
		strcpy(d_data, src.d_data);
		d_measure = src.d_measure;
	}
	~DNAList(void){
		delete[] d_data;
	}
	void set_DNA_length(const size_t& length){
		delete[] d_data;
		d_data = new char[length + 1];
		d_measure = 0;
	}
	unsigned int measure(void){
		return d_measure;
	}
	bool operator > (const DNAList& example){
		return d_measure > example.d_measure;
	}
	bool operator < (const DNAList& example){
		return d_measure < example.d_measure;
	}
	bool operator == (const DNAList& example){
		return d_measure == example.d_measure;
	}
private:
	char* d_data;
	unsigned int d_measure;
};

istream& operator >> (istream& in, DNAList& example){
	in >> example.d_data;
	size_t i, j;
	for (i = 0; example.d_data[i] != '\0'; ++i){
		for (j = i + 1; example.d_data[j] != '\0'; ++j){
			if (example.d_data[i] > example.d_data[j]){
				++example.d_measure;
			}
		}
	}
	return in;
}

ostream& operator << (ostream& out, const DNAList& example){
	out << example.d_data;
	return out;
}

void sort(DNAList* ptr, const size_t& size){
	size_t i, j;
	char* temp_data;
	unsigned int temp_measure;
	for (j = 0; j < size; ++j){
		for (i = 0; i < size - 1 - j; ++i){
			if (ptr[i] > ptr[i + 1]){
				temp_data = ptr[i].d_data;
				temp_measure = ptr[i].d_measure;
				ptr[i] = ptr[i + 1];
				ptr[i + 1].d_data = temp_data;
				ptr[i + 1].d_measure = temp_measure;
			}
		}
	}
}

int main(void){
	DNAList* DNA_list_lib;
	size_t DNA_length;
	size_t lib_size;
	while (cin >> DNA_length >> lib_size){
		DNA_list_lib = new DNAList[lib_size];
		for (size_t index(0); index != lib_size; ++index){
			DNA_list_lib[index].set_DNA_length(DNA_length);
			cin >> DNA_list_lib[index];
		}
		sort(DNA_list_lib, lib_size);
		for (size_t index(0); index != lib_size; ++index){
			cout << DNA_list_lib[index] << endl;
		}
		delete[] DNA_list_lib;
	}
	return EXIT_SUCCESS;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值