贪心问题 HDU 1051

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10136    Accepted Submission(s): 4167


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
此题大意是说给你N根木头的长度和重量,制作第一根木头时需要一分钟,以后每根木头的长度和重量只要都比前一根大就不需要建立时间,否则需要加一分钟,让你求最少时间。这是一道贪心题目,首先,将所有的木头按照长度从小到大排序,然后比较重量就可以了。可能你还有点迷糊,看一下代码你就明白了。
#include<stdio.h>  
#include<string.h>  
#include<algorithm>  
using namespace std;  
struct sa  
{  
    int l;  
    int w;  
}data[10000];  
int cmp(sa a,sa b)  
{  
    if(a.l!=b.l)  
    return a.l<b.l;  
    return a.w<b.w;  
}  
int z[10000];  
int main()  
{  
    int n;  
    while(scanf("%d",&n)!=EOF)  
    {  
        for(int a=0;a<n;a++)  
        {  
            int t;  
            scanf("%d",&t);  
            for(int b=0;b<t;b++)  
            {  
             scanf("%d%d",&data[b].l,&data[b].w);  
            }  
            sort(data,data+t,cmp);  
            memset(z,0,sizeof(z));  
            int x=0,y=0,i=0,j=0,time=0,k=0;  
            while(k<t)  
            {  
               for(i=j;i<t;i++)  
               if(z[i]==0)  
               {  
                   z[i]=1;  
                   j=i+1;  
                   x=data[i].l;  
                   y=data[i].w;  
                   k++;  
                   break;  
               }  
               for(i=j;i<t;i++)  
               {  
                   if(z[i]==0&&x<=data[i].l&&y<=data[i].w)  
                   {  
                      z[i]=1;  
                      x=data[i].l;  
                      y=data[i].w;  
                      k++;  
                   }  
  
               }  
               time++;  
            }  
            printf("%d\n",time);  
        }  
  
    }  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值