A + B Problem II(大数问题)

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
用字符串做:
#include<stdio.h>
#include<string.h>
char str1[1005],str2[1005],str[1005];
int main(){
    int t;
    while(scanf("%d",&t)!=EOF){
    //scanf("%d",&t);
    getchar();
    int cases=1;
    while(t--){
        if(cases!=1)
            printf("\n");
        scanf("%s%s",str1,str2);
        int i,j,temp=0,k=0;
        int len1=strlen(str1),len2=strlen(str2);
        for(i=len1-1,j=len2-1;i>=0 && j>=0;i--,j--){
            temp+=(str1[i]-'0')+(str2[j]-'0');
            str[k++]=(temp+'0');
            temp/=10;
        }
        if(i<0 && j<0 && temp!=0)
            str[k++]=(temp+'0');
        while(i>=0){
            temp+=(str1[i--]-'0');
            str[k++]=(temp+'0');
            temp/=10;
        }
        while(j>=0){
            temp+=(str2[j--]-'0');
            str[k++]=temp+'0';
            temp/=10;
        }
        if(temp!=0)
            str[k++]=(temp+'0');
        printf("Case %d:\n",cases);
        printf("%s + %s = ",str1,str2);
        for(i=k-1;i>0;i--)
            printf("%c",str[i]);
        printf("%c\n",str[i]);
        cases++;
    }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值