1065. A+B and C (64bit) 大数的加减


Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false

Case #2: true

Case #3: false

思路:  大数的加减。。。。。仅此而已

#include<iostream>
# include<cstdio>
# include<cstring>
using namespace std;
const int maxn=1000+5;
bool flag;
char a[maxn],b[maxn],c[maxn],d[maxn];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        flag=0;cin>>a>>b>>c;
    int x,y,z,i,j,h,tot;
    tot=0;
    x=strlen(a)-1;
    y=strlen(b)-1;
    z=strlen(c)-1;
     memset(d,'\0',sizeof(d));
     for(i=0;x>=0||y>=0;i++,x--,y--)
     {
         if(x>=0&&y>=0) d[i]=a[x]+b[y]-'0'+tot;
         if(x>=0&&y<0) d[i]=a[x]+tot;
         if(x<0&&y>=0) d[i]=b[x]+tot;
         tot=0;
         if(d[i]>'9') {d[i]-=10;tot=1;}
     }
      if(tot==1)  d[i]='1';
    h=strlen(d)-1;

    if(h>z)
        cout<<">"<<endl;
    else if(h<z)
        cout<<"<"<<endl;
    else
    {
        for(j=0,i=h;j<=z||i>=0;j++,i--)
        {
            if(d[i]>c[j])
            {cout<<">"<<endl;
                break;
            }
            else  if(d[i]<c[j])
            {
                cout<<"<"<<endl;
                break;
            }
           if(j==z) flag=1;
        }
        if(flag) cout<<"="<<endl;
      }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值