hdu 1195 Open the Lock 暴力穷举

Open the Lock

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3972    Accepted Submission(s): 1728


Problem Description
Now an emergent task for you is to open a password lock. The password is consisted of four digits. Each digit is numbered from 1 to 9. 
Each time, you can add or minus 1 to any digit. When add 1 to '9', the digit will change to be '1' and when minus 1 to '1', the digit will change to be '9'. You can also exchange the digit with its neighbor. Each action will take one step.

Now your task is to use minimal steps to open the lock.

Note: The leftmost digit is not the neighbor of the rightmost digit.
 

Input
The input file begins with an integer T, indicating the number of test cases. 

Each test case begins with a four digit N, indicating the initial state of the password lock. Then followed a line with anotther four dight M, indicating the password which can open the lock. There is one blank line after each test case.
 

Output
For each test case, print the minimal steps in one line.
 

Sample Input
  
  
2 1234 2144 1111 9999
 

Sample Output
  
  
2 4
 
思路:  数字只有四个,穷举才24种.  用逆序数来计算移动了几次.  




#include<algorithm>
#include<stdlib.h>
#include<vector>
#include<algorithm>
using namespace std;


int main()
{
	int t,i,j,k;
	int tem1,tem2;
	char a[20],b[20];//输入的数
	int n[20],m[20];//把输入的存成int
	int num[40];
	int nixu[10];// 0 1 2 3  开始 不断变化  求逆序数
	int sumnixu;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s",a);
		scanf("%s",b);
		for(i=0;i<4;i++)
		{
			n[i]=a[i]-'0';
			m[i]=b[i]-'0';
		    nixu[i]=i;
		}
		memset(num,0,sizeof(num));
		int minop=999999;
		for(i=0;i<24;i++)//第几种排序
		{
			sumnixu=0;//这种排序下 逆袭数大小,也就是exchange了几次
			for(j=0;j<4;j++)
			{
				
				tem2=max(n[nixu[j]],m[j]);
				tem1=min(n[nixu[j]],m[j]);//nixu数组 存的0123  .变化后代表n的下标.同时可以用来求逆序数
				num[i]+=min(tem2-tem1,9-tem2+tem1);
			    for(k=j+1;k<4;k++)//计算逆序数;
				{
					if(nixu[k]<nixu[j])
						sumnixu++;
				}
				
			}
			next_permutation(nixu,nixu+4); //全排列函数  头文件是algorithm .
			//printf("%d\n",sumnixu);
			num[i]+=sumnixu;
		    if(minop>num[i])
				minop=num[i];
		}
		printf("%d\n",minop);
	}
	return 0;
}
		



  
  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值