Magical Forest
Time Limit: 24000/12000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 324 Accepted Submission(s): 153
Problem Description
There is a forest can be seen as N * M grid. In this forest, there is some magical fruits, These fruits can provide a lot of energy, Each fruit has its location(Xi, Yi) and the energy can be provided Ci.
However, the forest will make the following change sometimes:
1. Two rows of forest exchange.
2. Two columns of forest exchange.
Fortunately, two rows(columns) can exchange only if both of them contain fruits or none of them contain fruits.
Your superior attach importance to these magical fruit, he needs to know this forest information at any time, and you as his best programmer, you need to write a program in order to ask his answers quick every time.
However, the forest will make the following change sometimes:
1. Two rows of forest exchange.
2. Two columns of forest exchange.
Fortunately, two rows(columns) can exchange only if both of them contain fruits or none of them contain fruits.
Your superior attach importance to these magical fruit, he needs to know this forest information at any time, and you as his best programmer, you need to write a program in order to ask his answers quick every time.
Input
The input consists of multiple test cases.
The first line has one integer W. Indicates the case number.(1<=W<=5)
For each case, the first line has three integers N, M, K. Indicates that the forest can be seen as maps N rows, M columns, there are K fruits on the map.(1<=N, M<=2*10^9, 0<=K<=10^5)
The next K lines, each line has three integers X, Y, C, indicates that there is a fruit with C energy in X row, Y column. (0<=X<=N-1, 0<=Y<=M-1, 1<=C<=1000)
The next line has one integer T. (0<=T<=10^5)
The next T lines, each line has three integers Q, A, B.
If Q = 1 indicates that this is a map of the row switching operation, the A row and B row exchange.
If Q = 2 indicates that this is a map of the column switching operation, the A column and B column exchange.
If Q = 3 means that it is time to ask your boss for the map, asked about the situation in (A, B).
(Ensure that all given A, B are legal. )
The first line has one integer W. Indicates the case number.(1<=W<=5)
For each case, the first line has three integers N, M, K. Indicates that the forest can be seen as maps N rows, M columns, there are K fruits on the map.(1<=N, M<=2*10^9, 0<=K<=10^5)
The next K lines, each line has three integers X, Y, C, indicates that there is a fruit with C energy in X row, Y column. (0<=X<=N-1, 0<=Y<=M-1, 1<=C<=1000)
The next line has one integer T. (0<=T<=10^5)
The next T lines, each line has three integers Q, A, B.
If Q = 1 indicates that this is a map of the row switching operation, the A row and B row exchange.
If Q = 2 indicates that this is a map of the column switching operation, the A column and B column exchange.
If Q = 3 means that it is time to ask your boss for the map, asked about the situation in (A, B).
(Ensure that all given A, B are legal. )
Output
For each case, you should output "Case #C:" first, where C indicates the case number and counts from 1.
In each case, for every time the boss asked, output an integer X, if asked point have fruit, then the output is the energy of the fruit, otherwise the output is 0.
In each case, for every time the boss asked, output an integer X, if asked point have fruit, then the output is the energy of the fruit, otherwise the output is 0.
Sample Input
1 3 3 2 1 1 1 2 2 2 5 3 1 1 1 1 2 2 1 2 3 1 1 3 2 2
Sample Output
Case #1: 1 2 1HintNo two fruits at the same location.
题意是n*m大的方格, 输入k组数据 x,y,c 代表x,y这个点上的值为c,没提到的值为0;
然后输入t 组数据 q,a,b ; 如果q是1,交换ab两行,如果q是2,交换ab两列;如果q是3,输出x=a,y=b上的值;
采用map来做,比较快. 其实的c值记录的坐标在zuobiao这个map中. 行列交换互不影响, 所以分开记录在hang 和lie 两个map中
hang[ a ] 为例, a是现在要查的行; hang[a] 中记录的值是 当前第a行上的数是 原来是第hang[a] 行;
如果hang[a] 没访问过, 就代表 a 行 就是开始的 a 行,
所以查找现在的a行b列的值, 就是查找 zuobiao[ hang[a] ][ lie[b] ] 上的值;
#include<stdio.h>
#include<map>
#include<vector>
#include<set>
using namespace std;
map<int,int>lie;
map<int,int>hang;
map<pair<int,int>,int> zuobiao;
void init()
{
hang.clear();
lie.clear();
zuobiao.clear();
}
int main()
{
int cas=1,r,c,zhi,t,q,a,b;
int n,m,k,tema,temb,w;
scanf("%d",&w);
while(w--)
{
printf("Case #%d:\n",cas++);
init();
scanf("%d%d%d",&n,&m,&k);
while(k--)
{
scanf("%d%d%d",&r,&c,&zhi);
zuobiao[make_pair<int,int>(r,c)]=zhi;
}
scanf("%d",&t);
while(t--)
{
scanf("%d%d%d",&q,&a,&b);
if(q==1)
{
if(hang.count(a))
tema=hang[a];
else
tema=a;
if(hang.count(b))
temb=hang[b];
else
temb=b;
hang[a]=temb;
hang[b]=tema;
}
else if(q==2)
{
if(lie.count(a))
tema=lie[a];
else
tema=a;
if(lie.count(b))
temb=lie[b];
else
temb=b;
lie[a]=temb;
lie[b]=tema;
}
else if(q==3)
{
if(hang.count(a))
a=hang[a];
if(lie.count(b))
b=lie[b];
if(zuobiao.count(make_pair(a,b)))
printf("%d\n",zuobiao[make_pair(a,b)]);
else
puts("0");
}
}
}
return 0;
}
/*
3 3 3
1 1 1
2 3 3
3 2 2
3
1 1 3
1 2 3
3 3 3
3 3 2
1 1 1
2 2 2
5
3 1 1
1 1 2
2 1 2
3 1 1
3 2 2
*/