矩阵变换: Magical Forest

题目描述

There is a forest can be seen as N * M grid. In this forest, there is some magical fruits, These fruits can provide a lot of energy, Each fruit has its location(Xi, Yi) and the energy can be provided Ci.

However, the forest will make the following change sometimes:
1. Two rows of forest exchange.
2. Two columns of forest exchange.
Fortunately, two rows(columns) can exchange only if both of them contain fruits or none of them contain fruits.

Your superior attach importance to these magical fruit, he needs to know this forest information at any time, and you as his best programmer, you need to write a program in order to ask his answers quick every time.

输入

The input consists of multiple test cases.

The first line has one integer W. Indicates the case number.(1<=W<=5)

For each case, the first line has three integers N, M, K. Indicates that the forest can be seen as maps N rows, M columns, there are K fruits on the map.(1<=N, M<=2*10^9, 0<=K<=10^5)

The next K lines, each line has three integers X, Y, C, indicates that there is a fruit with C energy in X row, Y column. (0<=X<=N-1, 0<=Y<=M-1, 1<=C<=1000)

The next line has one integer T. (0<=T<=10^5)
The next T lines, each line has three integers Q, A, B.
If Q = 1 indicates that this is a map of the row switching operation, the A row and B row exchange.
If Q = 2 indicates that this is a map of the column switching operation, the A column and B column exchange.
If Q = 3 means that it is time to ask your boss for the map, asked about the situation in (A, B).
(Ensure that all given A, B are legal. )

输出

For each case, you should output "Case #C:" first, where C indicates the case number and counts from 1.

In each case, for every time the boss asked, output an integer X, if asked point have fruit, then the output is the energy of the fruit, otherwise the output is 0.

样例输入

1
3 3 2
1 1 1
2 2 2
5
3 1 1
1 1 2
2 1 2
3 1 1
3 2 2

样例输出

Case #1:
1
2
1

提示

No two fruits at the same location.
    

分析: 

对矩阵的操作 

#include <bits/stdc++.h>
using namespace std;
int main(){
    int w;
    cin>>w;
    for(int l = 0;l<w;l++){
        int N,M,K;
        cin>>N>>M>>K;
        int matrix[N+1][M+1];
        memset(matrix,0,sizeof(matrix));
        int X,Y,C;

        for(int i = 0;i<K;i++){
            cin>>X>>Y>>C;
            matrix[X][Y] = C;
        }

        int T,Q,A,B;
        cin>>T;
        cout<<"Case #"<<l+1<<":"<<endl;
        for(int p = 0;p<T;p++){
            cin>>Q>>A>>B;
            if(Q == 1){//交换两行
                int flag1 = 0,flag2 = 0;
                for(int i = 1;i <= M;i++){//判断行是否为零
                    if(matrix[A][i]){
                        flag1 = 1;
                        break;
                    }
                }
                for(int i = 1;i <= M;i++){
                    if(matrix[B][i]){
                        flag2 = 1;
                        break;
                    }
                }
                if(flag2&&flag1){//如果不全为0
                    for(int i = 1;i <= M;i++){
                        int tmp = matrix[A][i];
                        matrix[A][i] = matrix[B][i];
                        matrix[B][i] = tmp;
                    }
                }
            }
            else if(Q == 2){//交换两列
                int flag1 = 0,flag2 = 0;
                for(int i = 1;i <= N;i++){//判断列是否为0
                    if(matrix[i][A]){
                        flag1 = 1;
                        break;
                    }
                }
                for(int i = 1;i <= N;i++){
                    if(matrix[i][B]){
                        flag2 = 1;
                        break;
                    }
                }
                if(flag2&&flag1){//两列不全为0时
                    for(int i = 1;i <= N;i++){
                        int tmp = matrix[i][A];
                        matrix[i][A] = matrix[i][B];
                        matrix[i][B] = tmp;
                    }
                }
            }
            else{
                cout<<matrix[A][B]<<endl;
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值