hdu 5323 Solve this interesting problem dfs 搜索

链接:http://acm.hdu.edu.cn/showproblem.php?pid=5323

Solve this interesting problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1470    Accepted Submission(s): 420


Problem Description
Have you learned something about segment tree? If not, don’t worry, I will explain it for you.
Segment Tree is a kind of binary tree, it can be defined as this:
- For each node u in Segment Tree, u has two values:  Lu  and  Ru .
- If  Lu=Ru , u is a leaf node. 
- If  LuRu , u has two children x and y,with  Lx=Lu , Rx=Lu+Ru2 , Ly=Lu+Ru2+1 , Ry=Ru .
Here is an example of segment tree to do range query of sum.
Given two integers L and R, Your task is to find the minimum non-negative n satisfy that: A Segment Tree with root node's value  Lroot=0  and  Rroot=n contains a node u with  Lu=L  and  Ru=R .
 

Input
The input consists of several test cases. 
Each test case contains two integers L and R, as described above.
0LR109
LRL+12015
 

Output
For each test, output one line contains one integer. If there is no such n, just output -1.
 

Sample Input
  
  
6 7 10 13 10 11
 

Sample Output
  
  
7 -1 12


题意:告诉你一个线段树有 一个区间 l到r,如果有这个种线段树  问根节点  0-n,  n最小是多少。如果没有输出-1

做法:搜索剪枝,主要那个剪枝右边界比较难想 比较重要。


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
#define inf 100000000000
typedef long long ll;
ll ans;

void dfs(ll l,ll r)
{
	if(l<0) return ;//越界
	if(l==0) {ans=min(ans,r); return;}//符合要求 取最小值
	if(l<(r-l+1)) return ;
	//l 这个区间 右边空余的长度,   r-l+1  是这个区间的长度
	//要对称,所以左边空白区间  必须是 这个区间的 某一倍数,可以相等,但是必须要大于等于 当前这个区间。
	//用于限制r的增长
	ll len=r-l+1;
	dfs(l-len,r);
	dfs(l-len-1,r);

	dfs(l,r+len);
	if(l!=r)
	dfs(l,r+len-1);
}
int main()
{
    ll l,r;
    while(scanf("%I64d%I64d",&l,&r)!=EOF){ 
		ans=inf;
		dfs(l,r);
		if(ans==inf)
			puts("-1"); 
		else
		printf("%I64d\n",ans);
	}
	return 0;
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值