hdu 5323 Solve this interesting problem dfs搜索

7 篇文章 0 订阅

Solve this interesting problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1431    Accepted Submission(s): 404


Problem Description
Have you learned something about segment tree? If not, don’t worry, I will explain it for you.
Segment Tree is a kind of binary tree, it can be defined as this:
- For each node u in Segment Tree, u has two values:  Lu  and  Ru .
- If  Lu=Ru , u is a leaf node. 
- If  LuRu , u has two children x and y,with  Lx=Lu , Rx=Lu+Ru2 , Ly=Lu+Ru2+1 , Ry=Ru .
Here is an example of segment tree to do range query of sum.



Given two integers L and R, Your task is to find the minimum non-negative n satisfy that: A Segment Tree with root node's value  Lroot=0  and  Rroot=n contains a node u with  Lu=L  and  Ru=R .
 

Input
The input consists of several test cases. 
Each test case contains two integers L and R, as described above.
0LR109
LRL+12015
 

Output
For each test, output one line contains one integer. If there is no such n, just output -1.
 

Sample Input
  
  
6 7 10 13 10 11
 

Sample Output
  
  
7 -1 12
 

Source

给出线段树的一个区间,问满足的树【0,n】的n


由于,线段树的每个节点,的左区间可能比右区间大一,所以向上回溯的时候,就出现了四种情况,记录len为区间长度


还需要剪枝,如果r>=res 则不需要继续了,或者r>2*rr也不需要了


#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
long long l,r;
long long res;
long long MIN(long long a,long long b)
{
    if(a<b) return a;
    else return b;
}
void dfs(long long ll,long long rr)
{
    if(rr>=res||rr>2*r) return ;
    if(ll==0)
    {
        res=rr;
        return ;
    }

    long long len=rr-ll+1;
    if(ll-len>=0)
        dfs(ll-len,rr);
    if(ll-len>=1)
        dfs(ll-len-1,rr);
    dfs(ll,rr+len);
    dfs(ll,rr+len-1);
}
int main()
{
    while(~scanf("%lld%lld",&l,&r))
    {
        res=1e16;
        dfs(l,r);
        if(res==1e16) cout<<"-1"<<endl;
        else cout<<res<<endl;
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值