PAT_ADVANCED LEVEL 1002 多项式加法

1002. A+B for Polynomials (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
 
 
NOTE: 没啥好说的,和合并链表是一个道理。但是不要忽略了不要输出零,如果忽略了这个,只能得15分,有十分会因为这个问题得不到。
上AC代码:
/*
	@ NAME		: A+B for Polynomials (25)
	@ AUTHOR	: GAOMINQUAN
	@ DATA		: 2014 - 2 - 26
	@ HARD		: NORMAL ***
	@ MAIL		: ensoleilly@gmail.com
 */
#include<iostream>
#include<vector>
#include<algorithm>

using namespace std;

struct Num{
	double coe;
	int exp;
	Num(double coe,int exp){
		this->coe = coe;
		this-> exp = exp;
	}
};

void initNumber(vector<Num> &number,int N){
	//cout<<"N = "<<endl;
	while(N--){
		double coe;
		int exp;
		cin>>exp>>coe;
		Num newNum = Num(coe,exp);
		number.push_back(newNum);
	}
}

vector<Num> add(vector<Num> number1,vector<Num> number2){
	int index1 = 0;
	int index2 = 0;
	
	int lengthNum1 = number1.size();
	int lengthNum2 = number2.size();

	vector<Num> addResult;
	
	while(index1 < lengthNum1 && index2 <lengthNum2){

		if(( number1[index1].exp == number2[index2].exp) || (number1[index1].coe + number2[index2].coe == 0)){

			double addCoe = number1[index1].coe + number2[index2].coe;
			Num newNum = Num(addCoe,number1[index1].exp);
			
			if( addCoe != 0){
				addResult.push_back(newNum);
			}
			//可以输入零,但是不能输出零

			index1++;
			index2++;
		}else if( number1[index1].exp > number2[index2].exp){
			while(number1[index1].exp > number2[index2].exp && index1 < lengthNum1){
				addResult.push_back(number1[index1]);
				index1 += 1;
			}
		}else if( number1[index1].exp < number2[index2].exp){
			while( number2[index2].exp > number1[index1].exp && index2 < lengthNum2){
				addResult.push_back(number2[index2]);
				index2 += 1;
			}
		}
	}

	if(index1 >= lengthNum1 && index2 < lengthNum2){
		for(int start2 = index2; start2 <lengthNum2; start2++){
			addResult.push_back(number2[start2]);
		}
	}

	if(index1 < lengthNum1 && index2 >= lengthNum2){
		for(int start1 = index1; start1 < lengthNum1; start1++){
			addResult.push_back(number1[start1]);
		}
	}

	return addResult;
}


void print_vector(vector<Num> numbers){
	for(int i = 0; i<numbers.size(); i++){
		printf("%d %0.1f",numbers[i].exp,numbers[i].coe);
		if(i!=numbers.size()-1){
			cout<<" ";
		}
	}
}
int main(){
	int N = 0;

	vector<Num> number1,number2;

	cin>>N;
	initNumber(number1,N);
	cin>>N;
	initNumber(number2,N);
	
	vector<Num> sum = add(number1,number2);
	if(sum.size()!=0){
		cout<<sum.size()<<" ";
	}else{
		cout<<0;
	}
	/*
	刚刚开始的时候,一直AC不过,原来是忽略了只输出零个的时候,应该只输出零,然后,把这句话加上。就完全合适了。
	*/
	print_vector(sum);

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值