POJ3468-A Simple Problem with Integers(线段树 成段更新求和)

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C abc" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q ab" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15
                                                                     

思路:线段树成段更新,区间求和。

                                                                                                                                                                                                                  Sotifish_DAccepted2352 KB1000 msG++1910 B 

CODE:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
const int inf=0xfffffff;
typedef long long ll;
using namespace std;

const int M=100005;
__int64 sumv[M<<2],addv[M<<2];

void build(int pos,int l,int r)
{
    addv[pos]=0;
    if(l==r) scanf("%lld",&sumv[pos]);
    else{
        int mid=(l+r)/2;
        build(pos*2,l,mid);
        build(pos*2+1,mid+1,r);
        sumv[pos]=sumv[pos*2]+sumv[pos*2+1];
    }
}
void maintain(int pos)
{
    sumv[pos]=sumv[pos*2]+sumv[pos*2+1];
}
void pushdown(int pos,int l,int r)
{
    int mid=(l+r)/2;
    addv[pos*2]+=addv[pos];
    sumv[pos*2]+=addv[pos]*(mid-l+1);
    addv[pos*2+1]+=addv[pos];
    sumv[pos*2+1]+=addv[pos]*(r-mid);
    addv[pos]=0;
}
void update(int pos,int l,int r,int x,int y,int v)
{
    if(x<=l && y >=r){
        addv[pos]+=(__int64)v;
        sumv[pos]+=(__int64)v*(r-l+1);
    }
    else{
        pushdown(pos,l,r);
        int mid=(l+r)/2;
        if(x <= mid) update(pos*2,l,mid,x,y,v);
        if(y > mid) update(pos*2+1,mid+1,r,x,y,v);
        maintain(pos);
    }
}
__int64 query(int pos,int l,int r,int x,int y)
{
    if(x<=l && y>=r) return sumv[pos];
    else{
        pushdown(pos,l,r); //一开始习惯性的写 if(addv[pos]>0 WA了n多遍T^T
        __int64 ans=0;
        int mid=(l+r)/2;
        if(x <=mid) ans += query(pos*2,l,mid,x,y);
        if(y > mid) ans += query(pos*2+1,mid+1,r,x,y);
        return ans;
    }
}
int main()
{
    //freopen("in.in","r",stdin);
    int N,Q;
    while(~scanf("%d%d",&N,&Q)){
        build(1,1,N);
        //getchar();
        char ch[4];
        int a,b,c;
        while(Q--){
            scanf("%s",ch);
            if(ch[0]=='C'){
                scanf("%d%d%d",&a,&b,&c);
                update(1,1,N,a,b,c);
            }
            else if(ch[0]=='Q'){
                scanf("%d%d",&a,&b);
                __int64 ans=query(1,1,N,a,b);
                printf("%lld\n",ans);
            }
            //getchar();
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值