POJ--3468--A Simple Problem with Integers(线段树)

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.

思路:线段树更新与求和模板

具体参考我写的模板:https://blog.csdn.net/queque_heiya/article/details/103987511

#include<iostream>
#include<cstdio>
#define ll long long
#define lson l, mid, rt<<1
#define rson mid + 1,r,rt<<1|1
using namespace std;
const int MAXN=1e5 + 10;
ll sum[MAXN<<2];
ll add[MAXN<<2];
void pushup(int rt){//向上更新
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void pushdown(int rt,int m){
    if(add[rt]){//若有标记,则将标记向下移动一层
        add[rt<<1]+=add[rt];
        add[rt<<1|1]+=add[rt];
        sum[rt<<1]+=(m-(m >> 1))*add[rt];
        sum[rt<<1|1]+=(m >> 1)*add[rt];
        add[rt]=0;//取消本层标记
    }
}
void build(int l,int r,int rt){//建树
    add[rt]=0;
    if(l==r){
        scanf("%lld",&sum[rt]);
        return;
    }
    int mid=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);//向上更新
}
void update(int L,int R,ll key,int l,int r,int rt){//区间更新
    if(L<=l &&R>=r){
        sum[rt]+=(r-l+1)*key;
        add[rt]+=key;
        return;
    }
    pushdown(rt, r-l+1);//向下更新
    int mid=(l+r)>>1;
    if(L<=mid) 
		update(L,R,key,lson);
    if(R>mid) 
		update(L,R,key,rson);
    pushup(rt);//向上更新
}
ll query(int L,int R,int l,int r,int rt){//区间求和
    if(L <= l && R >= r) 
		return sum[rt];
    pushdown(rt, r-l+1);//向下更新
    int mid=(l+r)>> 1;
    ll ans=0;
    if(L<=mid) 
		ans+=query(L, R, lson);
    if(R > mid) 
		ans+=query(L, R, rson);
    return ans;
}
int main(){
    int n, m;//n表示区间长度,m表示操作次数 
    scanf("%d%d", &n, &m);
    build(1, n, 1);
    while(m--){
        char str[3];//一般情况下用字符串数组 
/*	这里我们可以考虑这样:
	char ch;
	scanf("%c",&ch);//@@@ 
	if(ch=='C')//进行更新操作
	else//进行求和操作
	
	
	注意到在换行输入的时候,执行操作@@@会接收换行字符,程序自动结束,所以改用字符串数组;
    可以考虑用getchar()来解决单个字符问题;
*/ 
        int x, y;
        ll z;
        scanf("%s",str);
        if(str[0]=='C'){
            scanf("%d%d%lld",&x,&y,&z); 
            update(x,y,z,1,n,1);
        }else{
            scanf("%d%d",&x,&y);
            printf("%lld\n", query(x,y,1,n,1));//求和操作 
        }
    }
}
/*Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
/*   C表示给[a, b]区间中的值全部增加c
	 表Q示对[a, b]区间全求和 
Sample Output
4
55
9
15*/
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值