HDU 2298-Run(二分)

 

Description

The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.
We all like toxophily.

Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?

Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m.
 

Input

The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow's exit speed.
Technical Specification

1. T ≤ 100.
2. 0 ≤ x, y, v ≤ 10000.
 

Output

For each test case, output the smallest answer rounded to six fractional digits on a separated line.
Output "-1", if there's no possible answer.

Please use radian as unit.
 

Sample Input

    
    
3 0.222018 23.901887 121.909183 39.096669 110.210922 20.270030 138.355025 2028.716904 25.079551
 

Sample Output

  
  
1.561582 -1 -1

                                                                     

题意:给出目标的x,y 轴,和发射的速度,求出是否能够射中目标

思路:二分求解,将角度二分。

CODE:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
const int inf=0xfffffff;
typedef long long ll;
using namespace std;

double x,y,v;
const double eps=1e-8;
const double g=9.8;
const double pai=acos(-1.0);

double test(double j)
{
    double vx=v*cos(j);
    double vy=v*sin(j);
    double tx=x/vx;
    double yy=vy*tx-g*tx*tx/2;
    return yy;
}
int main()
{
    //freopen("in.in","r",stdin);
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%lf %lf %lf",&x,&y,&v);
        double l=0,r=pai/2.0 - eps;
        double mid;
        while(l<r){
            mid=(l+r)/2.0;
            if(fabs(test(mid)-y)<eps) break;
            if((test(mid)-y)>eps) r=mid;
            else l=mid;
        }
        if(l==r) printf("-1\n");
        else printf("%.6lf\n",mid);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值