CSU-ACM2017暑期训练5-三分 D - Toxophily HDU - 2298

题目:

The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.
We all like toxophily.

Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?

Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m.
Input
The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow's exit speed.
Technical Specification

1. T ≤ 100.
2. 0 ≤ x, y, v ≤ 10000.
Output
For each test case, output the smallest answer rounded to six fractional digits on a separated line.
Output "-1", if there's no possible answer.

Please use radian as unit.
Sample Input
3
0.222018 23.901887 121.909183
39.096669 110.210922 20.270030
138.355025 2028.716904 25.079551
Sample Output             1.561582             -1             -1

题意:一个果子在平面坐标的(x,y)处,你人在(0,0)处丢出一个速度为v的石子,问:使得石子能扔到果子的扔石子最小角度为多少(初速度与x轴的夹角)

思路:高中物理推出公式:y = v*sinθ*t -1/2*g*t*t,t = x / v*cosθ. 根据此公式三分求得可以达到果子的高度及以上高度的最大角度,然后在二分求得满足要求的最小角度

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
using namespace std;
typedef long long ll;
const double PI = acos(-1.0);
const double eps = 1e-6;
const int INF = 1000000000;
const int maxn = 100;
int T;
double x,y,v;
double l,r;

/*
    y = v*sinθ*t - 1/2*g*t*t,t = x / v*cosθ。
*/

double cal(double th)//th为的弧度
{
    double t=x/(v*cos(th));
    return v*sin(th)*t-4.9*t*t;
}

int main()
{
    scanf("%d",&T);
	while(T--)
    {
        scanf("%lf%lf%lf",&x,&y,&v);
        l=0,r=PI/2;
        if(x==0)
        {
            if(v*v/19.6>=y)//v^2=2gy
                printf("%.6f",PI/2);
            else
                printf("-1\n");
            continue;
        }
        for(int i=0;i<=100;i++)  
        {
            double mid,midmid;
            mid=(l+r)/2.0;
            midmid=(mid+r)/2.0;
            if(cal(mid)>cal(midmid))
                r=midmid;
            else
                l=mid;
        }
        if(cal(r)<y)
        {
            printf("-1\n");
            continue;
        }
        l=0;
        for(int i=0;i<=100;i++)
        {
            double mid=(l+r)/2.0;
            if(cal(mid)>y)
                r=mid;
            else
                l=mid;
        }
        printf("%.6f\n",r);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值