HDU 5014-Number Sequence

Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:

● a i ∈ [0,n]
● a i ≠ a j( i ≠ j )

For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):

t = (a 0 ⊕ b 0) + (a 1 ⊕ b 1) +···+ (a n ⊕ b n)


(sequence B should also satisfy the rules described above)

Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
 

Input
There are multiple test cases. Please process till EOF.

For each case, the first line contains an integer n(1 ≤ n ≤ 10 5), The second line contains a 0,a 1,a 2,...,a n.
 

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b 0,b 1,b 2,...,b n. There is exactly one space between b i and b i+1 (0 ≤ i ≤ n - 1). Don’t ouput any spaces after b n.
 

Sample Input
  
  
4 2 0 1 4 3
 

Sample Output
  
  
20 1 0 2 3 4

                                                                   

题意:

给出一列数只包括0~n (1<=n<=10^5)求出一个排列使得一一对应的异或值总和最大~

思路:

可以找到其规律,先写出0~10 的二进制数

0  0000 ,1  0001,2  0010,3  0011,4  0100, 5  0101,6 0110,7  0111,8  1000,9  1001, 10  1010

可以看出倘若每一个数所占的位数都为1 的话,那么得到的异或值就是最大的,而刚好得到的最大异或值减去原来的数就是得到的配对的数。

code:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
const int inf=0xfffffff;
typedef long long ll;
using namespace std;

int a[100005], ans[100005],n;

int cal(int n)
{
    int l = 0;
    while(n){
        n >>= 1;
        l ++;
    }
    return l;
}
int main()
{
    //freopen("in", "r", stdin);
    while(~scanf("%d", &n)){
        memset(ans, -1, sizeof(ans));
        for(int i = 0; i <= n; i ++){
            scanf("%d", &a[i]);
        }
        ll num,t,sum = 0;
        for(int i=n; i>=0; i--){
            if(ans[i] == -1){
                int len=cal(i);
                num = (1<<len) - 1;
                t = num^i;
                if(ans[t] == -1){
                    ans[i] = t;
                    ans[t] = i;
                    sum += (num*2);
                }
            }
        }
        printf("%d\n", sum);
        printf("%d", ans[a[0]]);
        for(int i=1;i<=n;i++){
            printf(" %d", ans[a[i]]);
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值