HDU 4451 - Dressing(容斥原理)

Description

Wangpeng has N clothes, M pants and K shoes so theoretically he can have N×M×K different combinations of dressing.
One day he wears his pants Nike, shoes Adiwang to go to school happily. When he opens the door, his mom asks him to come back and switch the dressing. Mom thinks that pants-shoes pair is disharmonious because Adiwang is much better than Nike. After being asked to switch again and again Wangpeng figure out all the pairs mom thinks disharmonious. They can be only clothes-pants pairs or pants-shoes pairs.
Please calculate the number of different combinations of dressing under mom’s restriction.
 

Input

There are multiple test cases.
For each case, the first line contains 3 integers N,M,K(1≤N,M,K≤1000) indicating the number of clothes, pants and shoes.
Second line contains only one integer P(0≤P≤2000000) indicating the number of pairs which mom thinks disharmonious.
Next P lines each line will be one of the two forms“clothes x pants y” or “pants y shoes z”.
The first form indicates pair of x-th clothes and y-th pants is disharmonious(1≤x≤N,1 ≤y≤M), and second form indicates pair of y-th pants and z-th shoes is disharmonious(1≤y≤M,1≤z≤K).
Input ends with “0 0 0”.
It is guaranteed that all the pairs are different.
 

Output

For each case, output the answer in one line.
 

Sample Input

    
    
2 2 2 0 2 2 2 1 clothes 1 pants 1 2 2 2 2 clothes 1 pants 1 pants 1 shoes 1 0 0 0
 

Sample Output

  
  
8 6 5

                                                          

题意:分别给出衣服,裤子,鞋子的个数,输出n个语句表示什么衣服不匹配什么裤子,什么裤子不匹配什么鞋子。求出衣服裤子鞋子的匹配数。

思路:容斥原理。先求出总的答案数,减去衣服和裤子,裤子和鞋子的不匹配数,再加上重复的。

          #一开始使用map把衣服裤子鞋子的英文表示为数字,超时了。实际上是没有必要的。

CODE:

#include <iostream>
#include <cstdio>
#include <map>
#include <vector>
#include <string>
using namespace std;

map<string, int> m;
vector<int> clothes[1005], pants[1005];
int sum = 0, n;

void work(int t, int ok)
{
    if(ok) {
        for(int i = 0; i < pants[t].size(); ++i){
            sum++;
        }
        return;
    }
    for(int i = 0; i < clothes[t].size(); ++i){
        work(clothes[t][i], ok + 1);
    }
}

int main()
{
//freopen("in", "r", stdin);
    m["clothes"] = 1; m["pants"] = 2; m["shoes"] = 3;
    int clot, pant, shoe;
    while(scanf("%d %d %d", &clot, &pant, &shoe)){
        if(clot + pant + shoe == 0) break;

        for(int i = 0; i < 1003; ++i){
            clothes[i].clear();
            pants[i].clear();
        }

        int ans = clot * pant * shoe;

        scanf("%d", &n);
        char a[10], b[10];
        int x, y;
        int pash = 0, copa = 0;
        for(int i = 0; i < n; ++i) {
            scanf("%s %d %s %d", a, &x, b, &y);
            if(a[0] == 'c') {
                copa++;
                clothes[x].push_back(y);
            }
            else {
                pash++;
                pants[x].push_back(y);
            }
        }
        ans -= (clot * pash);
        ans -= (shoe * copa);
        sum = 0;
        for(int i = 1; i <= clot; ++i) {
            if(clothes[i].size()) work(i, 0);
        }
        printf("%d\n", ans + sum);
    }
    return 0;
}

代码2 :

#include <iostream>
#include <cstdio>
#include <map>
#include <vector>
#include <string>
using namespace std;

map<string, int> m;
vector<int> clothes[1005], pants[1005];
int sum = 0, n;

void work(int t, int ok)
{
    if(ok) {
        for(int i = 0; i < pants[t].size(); ++i){
            sum++;
        }
        return;
    }
    for(int i = 0; i < clothes[t].size(); ++i){
        work(clothes[t][i], ok + 1);
    }
}

int main()
{
//freopen("in", "r", stdin);
    m["clothes"] = 1; m["pants"] = 2; m["shoes"] = 3;
    int clot, pant, shoe;
    while(scanf("%d %d %d", &clot, &pant, &shoe)){
        if(clot + pant + shoe == 0) break;

        for(int i = 0; i < 1003; ++i){
            clothes[i].clear();
            pants[i].clear();
        }

        int ans = clot * pant * shoe;

        scanf("%d", &n);
        char a[10], b[10];
        int x, y;
        int pash = 0, copa = 0;
        for(int i = 0; i < n; ++i) {
            scanf("%s %d %s %d", a, &x, b, &y);
            if(a[0] == 'c') {
                copa++;
                clothes[x].push_back(y);
            }
            else {
                pash++;
                pants[x].push_back(y);
            }
        }
        ans -= (clot * pash);
        ans -= (shoe * copa);
        sum = 0;
        for(int i = 1; i <= clot; ++i) {
            if(clothes[i].size()) work(i, 0);
        }
        printf("%d\n", ans + sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值