POJ 3278 - Catch That Cow(BFS)

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

                                                                                  

题意:

起点N, 终点K, 从起点到终点可以:1.走到N+1/N-1; 2.走到2×N。

思路:

一开始的想法有些类似贪心,简单粗暴的以为每次乘2到不能乘时做别的处理,但是可能每个点到终点的乘2最优点不是上一个点乘2得到的,所以不可以。

RightWay:从终点往回走,每次的点,若为偶数除以2,奇数则+1/-1. 使用BFS中的队列记录每一次的点,找到最小步数。

记得要加入判重数组,否则可能存在一个点左右来回走。

CODE:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <queue>
#include <cstring>

using namespace std;
const int INF = 1e8;
int N, K, Ans;
struct node { int n, step; };
queue<node> que;
int vis[200005];

int Abs(int x)
{
    return x<0?-x:x;
}

void bfs()
{
    memset(vis, 1, sizeof(vis));
    node q;
    q.n = K; q.step = 0;
    que.push(q);
    while(!que.empty()) {
        node now = que.front(); que.pop();
        int x = Abs(now.n - N);
        //if(x%2) x += 1;
        Ans = min(Ans, now.step + x);
        if(now.n % 2) {
            q.n = now.n + 1;
            q.step = now.step + 1;
            if(vis[q.n] && q.n < K + N) {
                que.push(q);
                vis[q.n] = 0;
            }
            q.n = now.n - 1;
            q.step = now.step + 1;
            if(q.n >= 1 && vis[q.n]) {
                 que.push(q);
                 vis[q.n] = 0;
            }
        }
        else {
            q.n = now.n / 2;
            q.step = now.step + 1;
            if(vis[q.n] && q.n >= 0) {
              que.push(q);
              vis[q.n] = 0;
            }
        }
    }

}
int main()
{
//freopen("in", "r", stdin);
    while(~scanf("%d%d", &N, &K)) {
        if(N >= K) {
            printf("%d\n", N - K);
            continue;
        }

        Ans = INF;
        bfs();

        printf("%d\n", Ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值