HDU 5025 - Saving Tang Monk(状压 + BFS)

 

Problem Description
《Journey to the West》(also 《Monkey》) is one of the Four Great Classical Novels of Chinese literature. It was written by Wu Cheng'en during the Ming Dynasty. In this novel, Monkey King Sun Wukong, pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to get sacred Buddhism texts.

During the journey, Tang Monk was often captured by demons. Most of demons wanted to eat Tang Monk to achieve immortality, but some female demons just wanted to marry him because he was handsome. So, fighting demons and saving Monk Tang is the major job for Sun Wukong to do.

Once, Tang Monk was captured by the demon White Bones. White Bones lived in a palace and she cuffed Tang Monk in a room. Sun Wukong managed to get into the palace. But to rescue Tang Monk, Sun Wukong might need to get some keys and kill some snakes in his way.

The palace can be described as a matrix of characters. Each character stands for a room. In the matrix, 'K' represents the original position of Sun Wukong, 'T' represents the location of Tang Monk and 'S' stands for a room with a snake in it. Please note that there are only one 'K' and one 'T', and at most five snakes in the palace. And, '.' means a clear room as well '#' means a deadly room which Sun Wukong couldn't get in.

There may be some keys of different kinds scattered in the rooms, but there is at most one key in one room. There are at most 9 kinds of keys. A room with a key in it is represented by a digit(from '1' to '9'). For example, '1' means a room with a first kind key, '2' means a room with a second kind key, '3' means a room with a third kind key... etc. To save Tang Monk, Sun Wukong must get ALL kinds of keys(in other words, at least one key for each kind).

For each step, Sun Wukong could move to the adjacent rooms(except deadly rooms) in 4 directions(north, west, south and east), and each step took him one minute. If he entered a room in which a living snake stayed, he must kill the snake. Killing a snake also took one minute. If Sun Wukong entered a room where there is a key of kind N, Sun would get that key if and only if he had already got keys of kind 1,kind 2 ... and kind N-1. In other words, Sun Wukong must get a key of kind N before he could get a key of kind N+1 (N>=1). If Sun Wukong got all keys he needed and entered the room in which Tang Monk was cuffed, the rescue mission is completed. If Sun Wukong didn't get enough keys, he still could pass through Tang Monk's room. Since Sun Wukong was a impatient monkey, he wanted to save Tang Monk as quickly as possible. Please figure out the minimum time Sun Wukong needed to rescue Tang Monk.
 

Input
There are several test cases.

For each case, the first line includes two integers N and M(0 < N <= 100, 0<=M<=9), meaning that the palace is a N×N matrix and Sun Wukong needed M kinds of keys(kind 1, kind 2, ... kind M).

Then the N × N matrix follows.

The input ends with N = 0 and M = 0.
 

Output
For each test case, print the minimum time (in minutes) Sun Wukong needed to save Tang Monk. If it's impossible for Sun Wukong to complete the mission, print "impossible"(no quotes).
 

Sample Input
  
  
3 1 K.S ##1 1#T 3 1 K#T .S# 1#. 3 2 K#T .S. 21. 0 0
 

Sample Output
  
  
5 impossible 8

                                                                                    

题意:

N * N (0<N<=100) 的矩阵,要求从K 到T 的最小步数,其中必须按顺序经过数字 0~ M(0 <= M <= 9),第一次经过蛇的时候要停留2,其他经过所花时间都为1。

思路:

本题主要是每一条蛇状态的记录,使用状态压缩,将每一条蛇的状态用二进制位记录下来,1代表活,0代表死。

使用vis四维数组记录每一点走过的状态,x,y分别表示位置,k 钥匙,s 表示蛇的状态,b 表示步数。

CODE:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
const int inf=0xfffffff;
typedef long long ll;
using namespace std;

char m[105][105];
int vis[105][105][15][40];
int dx[] = {0, 0, 1, -1}, dy[] = {1, -1, 0, 0};
int sx, sy, sn, N, M;
struct node
{
    int x, y, k, s, b;
};
queue<node> q;
int ans;

void bfs()
{
    node now;
    q.push((node){sx, sy, 0, 0, 0});
    while(!q.empty()){
        now = q.front();
        q.pop();
        int x = now.x, y = now.y, k = now.k, s = now.s, b = now.b;
        if(k == M && m[x][y] == 'T'){
            ans = min(ans, b);
        }

        if(vis[x][y][k][s] != 0) continue;
        vis[x][y][k][s] = 1;

        for(int i = 0; i < 4; i ++){
            int nx = x + dx[i], ny = y + dy[i];
            int snn = m[nx][ny] - 'A';

            if(snn >= 0 && snn < sn){
                if((1<<snn) & s) q.push((node) {nx, ny, k, s, b + 1});
                else q.push((node) {nx, ny, k,  (1<<snn) | s, b + 2});
            }
            else{
                if(m[nx][ny] == k + '1'){
                    q.push((node) {nx, ny, k + 1, s, b + 1});
                }
                else if(nx > 0 && nx <= N && ny > 0 && ny <= N && m[nx][ny] != '#')
                    q.push((node) {nx, ny, k, s, b + 1});
            }
        }
    }
}
int main()
{
    //freopen("in", "r", stdin);
    while(~scanf("%d %d", &N, &M)){
        if(N == 0 && M == 0) break;
        memset(m, 0, sizeof(m));
        memset(vis, 0, sizeof(vis));
        sn = 0;
        for(int i = 1; i <= N; i ++){
            scanf("%s", m[i] + 1);
            for(int j = 1; j <= N; j ++){
                if(m[i][j] == 'K'){
                    sx = i;
                    sy = j;
                }
                if(m[i][j] == 'S'){
                    m[i][j] = 'A' + sn;
                    sn ++;
                }
            }
        }
        ans = inf;
        bfs();
        if(ans == inf) printf("impossible\n");
        else printf("%d\n", ans);
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值