POJ 3083 - Children of the Candy Corn(BFS+DFS)

Description

The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit.

One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there's no guarantee which strategy (left or right) will be better, and the path taken is seldom the most efficient. (It also doesn't work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.)

As the proprieter of a cornfield that is about to be converted into a maze, you'd like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding visitors.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze layout. Walls are represented by hash marks ('#'), empty space by periods ('.'), the start by an 'S' and the exit by an 'E'.

Exactly one 'S' and one 'E' will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls ('#'), with the only openings being the 'S' and 'E'. The 'S' and 'E' will also be separated by at least one wall ('#').

You may assume that the maze exit is always reachable from the start point.

Output

For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the 'S' and 'E') for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.

Sample Input

2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########

Sample Output

37 5 5
17 17 9

-----------------------------------------------------

题意:

左转优先,输出路径; 右转优先,输出路径;输出最短路径。

思路:

最短路径使用BFS,

前两个使用DFS,因为有可能走过的路还会再走。要根据当前的位置决定下一步的方向。

使用queue之前记得清空。

CODE:

#include <iostream>
#include <cstdio>
#include <queue>
#include <algorithm>
#include <cstring>

using namespace std;
const int INF = 0xfffffff;
char maze[50][50];
int dis[50][50];
int dx[] = {-1,0,1,0}, dy[] = {0,1,0,-1};
int dl[] = {3,0,1,2}, dr[] = {1,0,3,2};
int w, h, sx, sy, fx, fy, cnt;
struct node { int x, y; };
queue<node> que;

bool textleft(int x, int y)
{
    if(x > 0 && x <= h && y > 0 && y <= w && maze[x][y] != '#')return true;
    return false;
}
void dfs_left(int d, int x, int y)
{
    cnt++;
    if(x == fx && y == fy) {
        printf("%d ", cnt);
        return;
    }
    for(int i = 0; i < 4; ++i) {
        int ndes = (d + dl[i]) % 4;
        int nx = x + dx[ndes], ny = y + dy[ndes];
        if(textleft(nx, ny)) {
            dfs_left(ndes, nx, ny);
            return;
        }
    }
}

bool textright(int x, int y)
{
    if(x > 0 && x <= h && y > 0 && y <= w && maze[x][y] != '#') return true;
    return false;
}
void dfs_right(int d, int x, int y)
{
    cnt++;
    if(x == fx && y == fy) {
        printf("%d ", cnt);
        return;
    }
    for(int i = 0; i < 4; ++i) {
        int ndes = (d + dr[i]) % 4;
        int nx = x + dx[ndes], ny = y + dy[ndes];
        if(textright(nx, ny)) {
            dfs_right(ndes, nx, ny);
            return;
        }
    }
}

bool text(int x, int y)
{
    if(x > 0 && x <= h && y > 0 && y <= w && maze[x][y] != '#' && dis[x][y] == -1)
        return true;
    return false;
}
void bfs()
{
    while(que.size()) que.pop();
    memset(dis, -1, sizeof(dis));
    node now, tmp;
    tmp.x = sx; tmp.y = sy;
    dis[sx][sy] = 1;
    que.push(tmp);

    while(que.size()) {
        now = que.front(); que.pop();
        if(now.x == fx && now.y == fy) {
            printf("%d\n", dis[fx][fy]);
            return;
        }
        for(int i = 0; i < 4; ++i) {
            int nx = now.x + dx[i], ny = now.y + dy[i];
            if(text(nx, ny)) {
                tmp.x = nx; tmp.y = ny;
                que.push(tmp);
                dis[nx][ny] = dis[now.x][now.y] + 1;
            }
        }
    }
}

int main()
{
//freopen("in", "r", stdin);
    int T;
    scanf("%d", &T);
    while(T--) {
        memset(maze, 0, sizeof(maze));

        scanf("%d %d", &w, &h);
        for(int i = 1; i <= h; ++i) {
            scanf("%s", maze[i]+1);
            for(int j = 1; j <= w; ++j) {
                if(maze[i][j] == 'S') {
                    sx = i; sy = j;
                }
                if(maze[i][j] == 'E') {
                    fx = i; fy = j;
                }
            }
        }
        int des;
        if(sx == 1) des = 0; if(sx == h) des = 2;
        if(sy == 1) des = 3; if(sy == w) des = 1;

        cnt = 0; dfs_left(des, sx, sy);
        cnt = 0; dfs_right(des, sx, sy);

        bfs();

    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值