HLG Catch The Cow

Catch That Cow
Time Limit: 2000 MSMemory Limit: 65536 K
Total Submit: 692(178 users)Total Accepted: 248(161 users)Rating: Special Judge: No
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

For each test case :

Line 1: Two space-separated integers: N and K

Process to the end of file.

Output

For each test case :

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17
100 100
Sample Output
4
0


#include <iostream>
#include <string.h>
#include <stdio.h>
#define maxn  200000 + 10


using namespace std;
int que[maxn];
int vis[maxn];


int bfs( int start, int end)
{
    int front = 0, back = 0, now;
    que[back++] = start;
    vis[start] = 0;


    while(front <= back)
    {
        now = que[front++];
        if(now == end)
          break;
        if(now+1 >= 0 && now +1 < maxn && vis[now+1] == -1)
        {
            vis[now+1] = vis[now] + 1;
            que[back++] = now + 1;


        }
        if(now-1 >= 0 && now -1 < maxn && vis[now-1] == -1)
        {
            vis[now - 1] = vis[now] + 1;
            que[back++] = now - 1;


        }
        if(now*2 >= 0 && now *2 < maxn && vis[now*2] == -1)
        {
            vis[now *2] = vis[now] + 1;
            que[back++] = now * 2;


        }
    }
    return vis[end];


}


int main()
{
    int n,k;
    while(cin>>n>>k)
   {
      memset(vis,-1,sizeof(vis));
     cout<<bfs(n,k)<<endl;
   }


}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值