hdu 1171 背包

20 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=1171

Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
  
  
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
  
  
20 10 40 40
将一系列数分成两部分,使两部分的差尽可能的小,而且若不能平均分成两部分要保证前者比后者大。

这其实就是一道背包的题目,将每一个a[i] 看做是一个物品,价值为a[i],所占用的空间也是a[i],背包容量为sum/2; 这样求出的就是分开后较小的哪一个数据。然后这个题就完了。

一开始真不敢写,很怕数组会越界,最后还是过了,不过也好悬

107476592014-05-15 21:26:18Accepted1171750MS19848K757 BC++life
下面是我的代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
int a[100005],dp[5000005];
int main()
{
    int x,y,n;
    int sum,sum1;
    while(~scanf("%d",&n))
    {
        if(n<=0)
            break;
        int k=1;
        sum=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&x,&y);
            sum+=x*y;
            while(y--)
            {
                a[k++]=x;
            }
        }
        sort(a+1,a+k);
        sum1=sum/2;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<k;i++)
            for(int j=sum1;j>=a[i];j--)
                dp[j]=max(dp[j],dp[j-a[i]]+a[i]);
        printf("%d %d\n",sum-dp[sum1],dp[sum1]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值