HDU 1171

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43672    Accepted Submission(s): 15012


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
  
  
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
  
  
20 10 40 40
题意:杭电的两个学院要财产,首先要求A学院分的财产要大于等于B学院分的财产。但是要求两个学院分的财产尽量相等 。
思路:把总财产先切一半当成背包就好了,然后就是背包问题了。
下面贴上代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define N 250005
#define M 5005

using namespace std;

int w[M],cnt[M];
int dp[N];

int main()
{
	int n;
	int i,j,x,y;
	while(~scanf("%d",&n),n>0)
	{
		memset(dp,0,sizeof(dp));
		memset(w,0,sizeof(w));
		memset(cnt,0,sizeof(cnt));
		int sum=0;
		int cout=0;
		for(i=1;i<=n;i++)
		{
		scanf("%d %d",&x,&y);
		while(y--)
		{
			w[++cout]=x;
			sum+=x;
		}
		}
		int kk=sum;
		sum/=2;
		for(i=1;i<=cout;i++)
		{
			for(j=sum;j>=w[i];j--)
				{
					dp[j]=max(dp[j],dp[j-w[i]]+w[i]);
				}
		}
		printf("%d %d\n",kk-dp[sum],dp[sum]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值