poj 1258 有向图变无向图 求最小生成树

http://vjudge.net/contest/view.action?cid=48211#problem/D

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28
题目大意:给定一个n*n的矩阵,a[i][j]表示从i到j有一条单向的路,矩阵是关于主对角线对称的。求最小生成树的路径长度。

解题思路:我们可以把它当做无向图来做,利用kruskal算法

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
struct note
{
    int start;
    int end;
    int w;
} edge[10025];
int pa[10005];
int n,m,k,p;
bool cmp(note a,note b)
{
    if(a.w<b.w)
        return true;
    return false;
}
void make_set()
{
    for(int x=0; x<=p; x++)
    {
        pa[x]=x;
    }
}
int find(int x)
{
    if(x!=pa[x])
        return pa[x]=find(pa[x]);
    return pa[x];
}
int kruskal()
{
    int i,ans=0;
    //printf("**\n");
    make_set();
    sort(edge,edge+p,cmp);
    for(i=0; i<p; i++)
    {
        int x=find(edge[i].start);
        int y=find(edge[i].end);
        //printf("%d,%d,\n",x,y);
        if(x!=y)
        {
            pa[y]=x;
            ans+=edge[i].w;
        }
    }
    return ans;
}
int main()
{
    int n,x;
    while(~scanf("%d",&n))
    {
        p=0;
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
            {
                scanf("%d",&x);
                if(i<j)
                {
                    edge[p].start=i;
                    edge[p].end=j;
                    edge[p].w=x;
                    //printf("(%d)\n",edge[p].w);
                    p++;
                }
            }
        printf("%d\n",kruskal());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值