hdu 3117矩阵+斐波那契数列

http://acm.hdu.edu.cn/showproblem.php?pid=3117

Fibonacci Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1720    Accepted Submission(s): 681


Problem Description
The Fibonacci sequence is the sequence of numbers such that every element is equal to the sum of the two previous elements, except for the first two elements f0 and f1 which are respectively zero and one.

What is the numerical value of the nth Fibonacci number?
 

Input
For each test case, a line will contain an integer i between 0 and 10 8 inclusively, for which you must compute the ith Fibonacci number fi. Fibonacci numbers get large pretty quickly, so whenever the answer has more than 8 digits, output only the first and last 4 digits of the answer, separating the two parts with an ellipsis (“...”). 

There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF).
 

Sample Input
  
  
0 1 2 3 4 5 35 36 37 38 39 40 64 65
 

Sample Output
  
  
0 1 1 2 3 5 9227465 14930352 24157817 39088169 63245986 1023...4155 1061...7723 1716...7565
题目大意:求一个斐波那契数列,如果其位数小于等于8,那么直接输出该数值,如果数位大于8,输出前四位和后四位,中间用“...”表示

大体思路:本题考查了斐波那契数列的运算,当然当n很小的情况下可以运用for循环求出,如果一旦n爆掉long long 那么我们对于本题该怎么求呢,首先,介绍一下对于斐波那契数列前几位数的求法




而对于求后几位我们完全可以利用矩阵来求,不能直接取模复杂度必须降到lg(n)。

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
int a[100];
const int MAX=2;
struct Matrix
{
    long long m[MAX][MAX];
};
Matrix P={0,1,
          1,1};
Matrix I={1,0,
          0,1};
Matrix matrixmul(Matrix a,Matrix b)
{
    int i,j,k;
    Matrix c;
    for(i=0;i<MAX;i++)
        for(j=0;j<MAX;j++)
        {
           c.m[i][j]=0;
           for(k=0;k<MAX;k++)
            c.m[i][j]+=(a.m[i][k]*b.m[k][j])%10000;
           c.m[i][j]%=10000;
        }
    return c;
}
Matrix quickpow(long long n)
{
    Matrix m=P,b=I;
    while(n>=1)
    {
        if(n&1)
            b=matrixmul(b,m);
        n=n>>1;
        m=matrixmul(m,m);
    }
    return b;
}
int main()
{
    int n;
    a[0]=0;
    a[1]=1;
    int temp;
    for(int i=2;;i++)
        if(a[i-1]+a[i-2]>99999999)
        {
           temp=i-1;
           break;
        }
        else
           a[i]=a[i-1]+a[i-2];
    while(~scanf("%d",&n))
    {
        Matrix tmp;
        tmp=quickpow(n);
        int ans_e=tmp.m[0][1];
        if(n<=temp)
            printf("%d\n",a[n]);
        else
        {
            int d;
            double len=0.0;
            len=log10(1.0/sqrt(5)) +(double)n*log10((1.0+sqrt(5))/2.0);
            d=(int)(pow(10,len-(int)len+3));
            printf("%d...%04d\n",d,ans_e);//将ans_e用0补齐四位
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值