HDU3117(快速幂)

Fibonacci Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1291    Accepted Submission(s): 545


Problem Description
The Fibonacci sequence is the sequence of numbers such that every element is equal to the sum of the two previous elements, except for the first two elements f0 and f1 which are respectively zero and one.

What is the numerical value of the nth Fibonacci number?
 

Input
For each test case, a line will contain an integer i between 0 and 10 8 inclusively, for which you must compute the ith Fibonacci number fi. Fibonacci numbers get large pretty quickly, so whenever the answer has more than 8 digits, output only the first and last 4 digits of the answer, separating the two parts with an ellipsis (“...”).

There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF).
 

Sample Input
  
  
0 1 2 3 4 5 35 36 37 38 39 40 64 65
 

Sample Output
  
  
0 1 1 2 3 5 9227465 14930352 24157817 39088169 63245986 1023...4155 1061...7723 1716...7565
 
 
//第四位运用矩阵的快速幂能够很好解决,但高四位就得结合数学知识,这个菜鸟不会
 
 
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <iostream> 
#include<cmath>
using namespace std;

//N表示矩阵的N次幂
int N;
const int mod=10000;
//此处假设矩阵为3*3阶
//origin存放需计算的矩阵,res存放答案矩阵
struct matrix
{
	int a[2][2];
}origin,res;

//直接将2个矩阵相乘x*y,返回计算后的矩阵
matrix multiply(matrix x,matrix y)
{
	matrix temp;
	memset(temp.a,0,sizeof(temp.a));
	for(int i=0;i<2;i++)
	{
		for(int j=0;j<2;j++)
		{
			for(int k=0;k<2;k++)
			{
				temp.a[i][j]=(temp.a[i][j]+(x.a[i][k]*y.a[k][j])%mod)%mod;
			}
		}
	}
	return temp;
}

//将res初始化为单位矩阵,人为输入origin
void init()
{
	origin.a[0][0]=origin.a[0][1]=origin.a[1][0]=1;
	origin.a[1][1]=0;
	//将res.a初始化为单位矩阵 
	memset(res.a,0,sizeof(res.a));
	res.a[0][0]=res.a[1][1]=1;                  
}

//矩阵快速幂的计算
void calc(int n)
{
	while(n)
	{
		if(n&1)
			res=multiply(res,origin);
		n>>=1;
		origin=multiply(origin,origin);
	}
}

void pre(int  n)  
{  
       double a=sqrt(5.0);  
       double b=(sqrt(5.0)+1)/2;  
       double s=log(1.0/a)/log(10.0)+n*log(b)/log(10.0);  
       double t=s-(int)s+3;  
       double f=pow(10.0,t);  
       f=(int)f;  
       cout<<f<<"...";  
}  

int f[40];
int main()
{
	int i;
	f[0]=0;f[1]=1;
	for(i=2;i<40;i++)
		f[i]=f[i-1]+f[i-2];
    while(cin>>N)
    {
		if(N<40)
		{
			printf("%d\n",f[N]);
			continue;
		}
		init();
		calc(N);
		pre(N);
		printf("%04d\n",res.a[1][0]);
    }
    return 0;
}

 
 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值