2014多校联合第一场 1004 Task

http://acm.hdu.edu.cn/showproblem.php?pid=4864

Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
 

Input
The input contains several test cases. 
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.
 

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
 

Sample Input
  
  
1 2 100 3 100 2 100 1
 

Sample Output
  
  
1 50004
题目大意:

               给出n个机器,m个工作任务,每个机器有一个x值和y值,每一个任务也有一个a值和b值,当 a>x&&b>y时该机器可以用来完成该项任务,每一个任务完成后将获得(500*xi+2*yi) 的价值,求在完成任务数最多的情况下使创造的价值最多。

简单思路:从题目中我们可以看出来,y值在0~100中取值,因此对价值的影响要比x小的多,因此我们按x降序优先的原则排序,然后依次安排每项任务的机器,对机器排序方式和任务的相同,我们在给任务安排机器的时候,找到其y值与任务y值相差最小的(因为后续的任务可能会有比该次的y值更大的)

杭电支持%I64d不支持%lld

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <map>
#include <algorithm>
using namespace std;
struct note
{
    int x,y;
}a[100005],b[100005];
bool cmp(note a,note b)
{
    if(a.x==b.x)
        return a.y>b.y;
    return a.x>b.x;
}
map<int,int>p;
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0;i<n;i++)
            scanf("%d%d",&a[i].x,&a[i].y);
        for(int i=0;i<m;i++)
            scanf("%d%d",&b[i].x,&b[i].y);
        sort(a,a+n,cmp);
        sort(b,b+m,cmp);
    int j=0,count=0;
    long long sum=0;
    p.clear();
    for(int i=0;i<m;i++)
    {
        while(j<n&&a[j].x>=b[i].x)
        {
            p[a[j].y]++;
            j++;
        }
        map<int,int>::iterator it=p.lower_bound(b[i].y);
        if(it!=p.end())
        {
            count++;
            sum+=(500*b[i].x+2*b[i].y);
            int t=it->first;
            p[t]--;
            if(p[t]==0)
                p.erase(t);
        }
    }
    printf("%d %I64d\n",count,sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值