2010成都站F题 三分

http://acm.hdu.edu.cn/showproblem.php?pid=3714

Problem Description
Josephina is a clever girl and addicted to Machine Learning recently. She
pays much attention to a method called Linear Discriminant Analysis, which
has many interesting properties.
In order to test the algorithm's efficiency, she collects many datasets.
What's more, each data is divided into two parts: training data and test
data. She gets the parameters of the model on training data and test the
model on test data. To her surprise, she finds each dataset's test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.



It's very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function's minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it's too hard for her to solve this problem. As a super programmer, can you help her?
 

Input
The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.
 

Output
For each test case, output the answer in a line. Round to 4 digits after the decimal point.
 

Sample Input
  
  
2 1 2 0 0 2 2 0 0 2 -4 2
 

Sample Output
  
  
0.0000 0.5000
题目大意:

                  给定多个二次函数保证开口向上,求在0~1000里面取一个数,使得所有二次函数中的最大值最小,求这个最小值。

解题思路:求一个单调函数的值我们用二分,同样的在求二次函数的极值点的时候我们用的是三分

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
int n;
double a[10005],b[10005],c[10005];
double judge(double x)
{
    double maxx=-0x3f3f3f3f;
    for(int i=0; i<n; i++)
    {
        double cnt=a[i]*x*x+b[i]*x+c[i];
        if(maxx<cnt)
            maxx=cnt;
    }
    return maxx;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0; i<n; i++)
            scanf("%lf%lf%lf",&a[i],&b[i],&c[i]);
        double l=0.0,r=1000.0;
        while(r-l>1e-9)
        {
            double mid=(l+r)/2;
            double midmid=(mid+r)/2;
            if(judge(mid)<judge(midmid))
                r=midmid;
            else
                l=mid;
        }
        //printf("%lf\n",r);
        printf("%.4lf\n",judge(r));
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值