HDU - 3714 (三分)
题目如下
Josephina is a clever girl and addicted to Machine Learning recently. She
pays much attention to a method called Linear Discriminant Analysis, which
has many interesting properties.
In order to test the algorithm’s efficiency, she collects many datasets.
What’s more, each data is divided into two parts: training data and test data. She gets the parameters of the model on training data and test the model on test data. To her surprise, she finds each dataset’s test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.
It’s very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function’s minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1…n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it’s too hard for her to solve this problem. As a super programmer, can you help her?
Input
The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.
Output
For each test case, output the answer in a line. Round to 4 digits after the decimal point.
Sample Input
2
1
2 0 0
2
2 0 0
2 -4 2
Sample Output
0.0000
0.5000
题目分析:
有点丑= =,就类似要求红色曲线的极值(蓝色曲线为所有ax²+bx+c的图像)
AC代码如下:
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=10005;
int n,a[maxn],b[maxn],c[maxn];
double f(double x) //该函数用以求用x=x的垂直直线与所有ax²+bx+c的交点的最大值
{
double MAX=a[0]*x*x+b[0]*x+c[0];
for(int i=1;i<n;i++)
{
MAX=max(MAX,a[i]*x*x+b[i]*x+c[i]);
}
return MAX;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d%d%d",&a[i],&b[i],&c[i]);//输入每个abc
double l=0,r=1000; //在区间[1,1000]内缩
while(r-l>1e-11)//注意精度,直到三分出极值
{
double mid=l+(r-l)/3; //三分模板
double mmid=r-(r-l)/3;
if(f(mid)<f(mmid)) r=mmid;
else l=mid;
}
printf("%.4f\n",f(l));
}
return 0;
}