hdu 4821 ||2013年长春站J题 字符串哈希+map的应用

26 篇文章 1 订阅
13 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=4821



Problem Description
Given a string S and two integers L and M, we consider a substring of S as “recoverable” if and only if
  (i) It is of length M*L;
  (ii) It can be constructed by concatenating M “diversified” substrings of S, where each of these substrings has length L; two strings are considered as “diversified” if they don’t have the same character for every position.

Two substrings of S are considered as “different” if they are cut from different part of S. For example, string "aa" has 3 different substrings "aa", "a" and "a".

Your task is to calculate the number of different “recoverable” substrings of S.
 

Input
The input contains multiple test cases, proceeding to the End of File.

The first line of each test case has two space-separated integers M and L.

The second ine of each test case has a string S, which consists of only lowercase letters.

The length of S is not larger than 10^5, and 1 ≤ M * L ≤ the length of S.
 

Output
For each test case, output the answer in a single line.
 

Sample Input
  
  
3 3 abcabcbcaabc
 

Sample Output
  
  
2
题目大意:

                  给定一个字符串在其中找出子串长度 m*l,并且该字串可分为m段每段长度均为l,求有多少个这样的子串。

解题思路:

                 利用哈希算出每个子串的哈希值,利用map,注意不能直接暴力一遍,会超时,技巧在代码。

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <map>
//#define debug
using namespace std;

typedef unsigned long long ULL;

const int SIZE = 100003;
const int SEED = 13331;
const int MAX_N = 110000 + 10;
char s[MAX_N];
struct HASH{
    ULL H[MAX_N];
    ULL XL[MAX_N];
    int len;
    HASH(){}
    void build(char *s){
        len=strlen(s);
        H[len]=0;
        XL[0]=1;
        for (int i=len-1;i>=0;i--){
            H[i]=H[i+1]*SEED+s[i];
            XL[len-i]=XL[len-i-1]*SEED;
        }
    }
    ULL hash(int i,int L){
        return H[i]-H[i+L]*XL[L];
    }
}hs;
char a[100005];
int n,m,cnt;
map<ULL,int> p;
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        scanf("%s",a);
        hs.build(a);
        int len=strlen(a);
        cnt=0;
        for(int i=0;i<m&&i<=(len-n*m);i++)
        {
            p.clear();
            for(int j=i;j<i+n*m;j+=m)
                p[hs.hash(j,m)]++;
            if(p.size()==n)
                cnt++;
            for(int j=i+n*m;j<=len-m;j+=m)
            {
                p[hs.hash(j-n*m,m)]--;
                if(p[hs.hash(j-m*n,m)]==0)
                    p.erase(hs.hash(j-m*n,m));
                p[hs.hash(j,m)]++;
                if(p.size()==n)
                    cnt++;
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}


Problem Description
Given a string S and two integers L and M, we consider a substring of S as “recoverable” if and only if
  (i) It is of length M*L;
  (ii) It can be constructed by concatenating M “diversified” substrings of S, where each of these substrings has length L; two strings are considered as “diversified” if they don’t have the same character for every position.

Two substrings of S are considered as “different” if they are cut from different part of S. For example, string "aa" has 3 different substrings "aa", "a" and "a".

Your task is to calculate the number of different “recoverable” substrings of S.
 

Input
The input contains multiple test cases, proceeding to the End of File.

The first line of each test case has two space-separated integers M and L.

The second ine of each test case has a string S, which consists of only lowercase letters.

The length of S is not larger than 10^5, and 1 ≤ M * L ≤ the length of S.
 

Output
For each test case, output the answer in a single line.
 

Sample Input
   
   
3 3 abcabcbcaabc
 

Sample Output
   
   
2
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值