2013长沙站A题||hdu4791 思维题

http://acm.hdu.edu.cn/showproblem.php?pid=4791

Problem Description
Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It's easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.
 

Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 10 5 ). The second line contains 2n integers s 1, p 1 , s 2, p 2 , ..., s n, p n (0=s 1 < s 2 < ... < s n ≤ 10 9 , 10 9 ≥ p 1 ≥ p 2 ≥ ... ≥ p n ≥ 0).. The price when printing no less than s i but less than s i+1 pages is p i cents per page (for i=1..n-1). The price when printing no less than s n pages is p n cents per page. The third line containing m integers q 1 .. q m (0 ≤ q i ≤ 10 9 ) are the queries.
 

Output
For each query q i, you should output the minimum amount of money (in cents) to pay if you want to print q i pages, one output in one line.
 

Sample Input
  
  
1 2 3 0 20 100 10 0 99 100
 

Sample Output
  
  
0 1000 1000
题目大意:购物时,当商品达到一定的数量就会相应的便宜,现在给出价格分流的点和各个区间的价格,求买x件物品使用怎样的方法能花费最少。

解题思路:求出x所在的价格,由于购买越多价格越低,因此之需要比较比x多的区间起点(即价格改变点)最低价格与不采取措施,直接购买的价格孰低孰高就可以了。查找x所在价格是用到了二分,否则会超时的。

#include <stdio.h>
#include <string.h>
#include <iostream>
//#define debug
using namespace std;
typedef unsigned long long ULL;
ULL sum[100005];
int a[100005],b[100005];
int n,m;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
            scanf("%d%d",&a[i],&b[i]);
        ULL minn=0x3f3f3f3f3f3f;
        for(int i=n-1;i>=0;i--)
        {
            minn=min((ULL)a[i]*b[i],minn);
            sum[i]=minn;
        }
        #ifdef debug
        for(int i=0;i<n;i++)
           printf("%I64d ",sum[i]);
        printf("\n");
        #endif
        while(m--)
        {
            int t,tmp;
            scanf("%d",&t);
            int l=0,r=n-1;
            while(l<=r)
            {
                int mid=(l+r)/2;
                if(a[mid]<=t)
                {
                    tmp=mid;
                    l=mid+1;
                }
                else
                    r=mid-1;
            }
            #ifdef  debug
             printf("(%d)\n",tmp);
            #endif
            if(tmp==n-1)
                printf("%I64d\n",t*b[tmp]);
            else
                printf("%I64d\n",min((ULL)t*b[tmp],sum[tmp+1]));
        }
    }
    return 0;
}
/**
3
3 33
0 4 5 3 10 1
**/


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值