hdu3555 数位dp

15 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=3555

Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.

/**
hdu 3555 数位dp
题目大意: 给定一个闭区间,求区间内有多少数中含“49”。
解题思路:dp[i][j]表示i位数以j为最高位位中的所有不符合数的个数。做一下预处理,求出10^6内的所有dp值,然后统计给定区间内的即可
           注意:eg:原数1347,转换到数组我表示为7431
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
typedef long long LL;

LL l;
LL dp[25][12];

void init()
{
    memset(dp,0,sizeof(dp));
    dp[0][0]=1;
    for(int i=1;i<21;i++)
    {
        for(int j=0;j<=9;j++)///最后一位的取值
        {
            for(int k=0;k<=9;k++)///倒数第二位的取值
            {
                if(!(j==4&&k==9))
                    dp[i][j]+=dp[i-1][k];
            }
        }
    }
/**
    for(int i=1;i<21;i++)
    {
        for(int j=0;j<=9;j++)
        {
            printf("%I64d ",dp[i][j]);
        }
        printf("\n");
    }*/
}
LL solve(LL n)
{
    int a[25],len=0;
    while(n>0)
    {
        a[++len]=n%10;
        n/=10;
    }
    a[len+1]=0;
    LL ans=0;
    for(int i=len;i>0;i--)
    {
        for(int j=0;j<a[i];j++)
        {
            if(!(a[i+1]==4&&j==9))
            {
                ans+=dp[i][j];
            }
        }
        if(a[i]==9&&a[i+1]==4)break;
    }
    return ans;
}

int main()
{
    int T;
    scanf("%d",&T);
    init();
    while(T--)
    {
        scanf("%I64d",&l);
        printf("%I64d\n",l+1-solve(l+1));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值